GPS shield V1.1 - never obtaining a fix

I received a new at V2 on 08/01/17 - GPS shield V1.1. To test the V1.1 shield, I removed the GPS shield from a running V1 AT and replaced it with the GPS shield V1.1.

After leave the it sit with red LED blinking for 2 hours with full sky view, it had not obtained a fix. I then added the active GPS antenna that I have been using on the V! AT (always get a fix in less than 60 seconds) and repeated the test - still not fix.

Is there something that I do not understand when using the GPS shield V1.1 or is it possible that I have a broken one?

Thank you

solved, Particle has changed the definition of the red LED from V1. On V2, the LED flashes when a fix has been acquired. Also one must use the latest libraries with V2. A set of release note would go a long way to making the V1 to V2 upgrade less frustrating.

Hey Jibeset,

Whee you able to have a fix with v2?

In my case I got a flashing bright red (which means fix is obtained), but the code always returned 0.00000 as lat and lng.

In the end I switched to AssetTrackerRK and it worked perfectly.
I have found the hint to make it work in this post of the community

I wonder why it didn’t with the official libraries…what do you think? How did it work for you?


I have always used AssetTrackerRK libraries even with my V1 trackers. When I started down the Tracker road, I had bad experiences with “the AssetTracker library” and switched to the AssetTrackerRK libraries with good success.

I do know that “the 0.0.10 version of the AssetTracker library” is required to support V2 but have never tested it. You need the latest version of the AssetTrackerRK libraries to support the V2 trackers.

I have had good success using the AssetTrackerRK libraries with the GP - 20U7 stand alone GPS receiver with an Electron.

In my application time to first fix is important. The V2 tracker meets my requirements as does the GP-20U7 receiver.