GPS Shield Issues - Electron Asset Tracker

I had the GPS Shield working great (after figuring out how to get a GPS lock the first time).

I have the coin cell installed, so locked fast after power downs.
Then, today I made some minor changes to my code, mostly the timeout (frequency of updates) to the cloud, uploaded/flashed the Electron.

Now, the LED light for the “fix” position on the GPS shield goes out quickly (as it did before), yet the Electron never updates (i.e. t.gpsFix() returns 0, even though the LED light has stopped blinking!). (checked via Serial)

I have tried to remove the coin battery, complete power cycle and re-flash.

Could the GPS Library have changed since I last compiled? How do I check that?

appears there are others that have seen this issue and reported on github

Could the use of an external antenna cause the GPS to fail? how can I debug the GPS?

I believe this to be a bug in the Adafruit GPS parser. I wrote a replacement library that is nearly a drop-in replacement for the official AssetTracker that uses the TinyGPS++ parser which I find to be much more reliable and eliminates the 0,0 coordinates after getting a fix problem.

This page describes it:

And then you can just use AssetTrackerRK instead of AssetTracker in the community libraries.

1 Like

@rickkas7 i did find you (or someone) mention TinyGPS++, but was having issues getting it to work… your version works GREAT! Thank you!

Strange that Particle’s library was working up until I tried an external antenna; which appears to be the same issue another person had who posted to github.

1 Like

Additon testing, something I should add, and maybe you can @rickkas7 in your code (if its already there, sorry).


Needs to be called VERY regularly. If your loop() function takes too long between calling updateGPS() I find that the code will still return 0,0 even if there is a fix.

When I get the chance, I’ll try the Particle library again.

I am in contact with particle support complaining that the devices delivered last week are not working. Basically I confirm the above: all Asset tracker run fine but don’t fix (outdoor, after 1h). TinyGPS++ has made it possible to fix once in a while, but only sporadic – not useful for customer.

Also I cannot afford an external antenna and t.b.h. adafruits GPS board runs with my Arduino fine. Thus the reason seems to be the setup or firmware of the GPS chip. Anyone who knows how to connect the PC Tool from MT to adjust the GPS parameters?
@rickkas7 Does TinyGPS send hardware commands to influence the tracking behaviour and can I adjust those?

@all Did anyone find the trick how to setup the electron that it fixes within 60s and hot start in 2s revolvingly?

@copterview here is a link to my other post that talks about “quick” fixing of positions and the first time

Basically, the first time I had to take mine for a drive, make sure the coin cell is installed, then it would fix quickly after the first lock.

The only issue I notice with it now, is if its not outside, the location can be off by over 100m (~300ft). Likely because indoors its lucky to get even 1 satellite fix.