Asset tracker GPS - wrongly indicated that a GPS fix is found


After I power on the Electron (with an external GPS antenna connected) the GPS led goes off in 15-20 secs indicating that a fix was found, yet it seems to return 0/0 as a supposedly valid lat/lon data for at least 10 minutes (while constantly having the led off and indicating that a fix was found).

On one hand. I would like to know if this is an isolated issue or if others are also seeing reads like this, on the other I would like to know if there is anything I can do to reduce the “real fix” times because if the requirement is to have a read every 10 mins it means that I can’t put the Electron to sleep because it would take more to find the proper position.

PS1: I tested with different libraries and it works like that regardless of the lib used.
PS2: I am not sure if it is worth mentioning that I am not in the Ocean close to Africa, so the 0/0 coordinates are definitely wrong.

Of course there are a lot of variables, but using the AssetTracker with an external active GPS antenna, inside but in front of a window, and the TinyGPS++ library, I typically get an initial fix time of 27-60 seconds from no power.

Adding the CR1220 coin cell battery is the really important thing, however. From Electron reset or sleep I can get a fix in 2 to 7 seconds with the battery.

When using the TinyGPS++ library the blinking of the red light seems to correspond to actually getting a fix. I’ve seen the situation you’ve described where the light stops blinking but reports 0,0 as the coordinates with the official AssetTracker/Adafruit library, though it only happens occasionally for me, not all the time.


Thanks for the feedback, I tried both the Asset Tracker and TinyGps. they both exhibit the same symptoms. I’ll try the ++ version. (I have the battery and within 2 to 7 seconds I only see the GPS light go off, but never the actual position.

I’ll report my findings with the TinyGps++.

Here’s the code that I used to test (3_WakeOnMove) in particular.


I have the exact same problem. GPS fix led goes off in about 20 seconds or so but the function returns 0. Has anybody found a fix or the reason behind it?

By the way I am trying Asset tracker example!

I’m pretty sure having the red GPS LED go off but still get a location of 0,0 is a bug in the Adafruit GPS parser in the official AssetTracker library.

I’d try my replacement library, AssetTrackerRK, linked to above. It’s also in the community libraries as “AssetTrackerRK.” It uses the TinyGPS++ GPS parser, which I find more reliable.

OK, I will try to work on it.

Perfect! Its working great now. Thanks a lot. How should the bug in the library be reported?

Glad my library worked!

You can use the Github issues feature to submit an issue in the official AssetTracker library here:

Make sure you include as much detail as possible about your setup and what happens.


I’m having similar experience. I’m using AssetTrackerRK, coin cell and external antenna. Even with the external antenna disconnected, I’m getting the GPS LED to stop flashing with 10s to 40s after hitting the Reset button. This is with the Shield located indoors. So I conclude that the hardware is getting a fix promptly. However, there is something peculiar going on, because I can’t get the LED to start flashing again even if I cover the shield with aluminum foil.

I’m not sure what would cause that behavior. If I move my AssetTracker v1 to my desk it usually loses its GPS fix within a few minutes and will begin blinking again.

I had the same issue and I fixed it by switching to rickkas7 library.

Thank’s @rickkas7 …you have a fanbase from now on.