Flashing core results in LED off

Most of the time why trying to flash my core it flashes magenta for a bit then the LED simply goes off. After a little delay it starts up again in the normal boot up sequence with the old firmware.

I’m using a wall power supply so I don’t think that’s the issue. I’ve tried my laptop too. I have also flashed the latest and greatest firmware from Github, and I think it worked.

I’m not really sure what else to do, thanks for the help in advance.

I’ve run into this problem when I’ve had poor wifi reception, or was experiencing the Cyan Flash of Death. When your code is running normally, is your wifi connection usually pretty good?


few things you can try:

  1. Do a CC3000-patch-firmware

  2. Upgrade your factory reset firmware to the latest V2.01

I had it before but with all the upgrades and stuff i did to my :spark:, all is good :slight_smile:

1 Like

It should be. I was noticing it dropping connection a lot earlier, that itself was weird though.

It would be connected without ANY issues for a long time. Then I would send it a function api call, the first call would work, the second call would work too, but the HTTP response would time out, then the core would disconnect.

I did that exact chain of events more than 5 times. Publish doesn’t seem to be causing disconnects for me.

You might try flashing via USB until the CC3000 patch is released. The patch will help a lot with stability during flashing. Or do what you can to make sure traffic on your wifi network is low (I setup a separate wifi network for just my sparkcores) to keep the CC3000 happy during flashing.

USB flashing is much faster anyway. It’s just more work to setup initially.

1 Like

I was having similar issues a while back and then set up a guest network on my router for my Cores. They ran rock-solid after that. However, I haven’t had much issue on my main network after the CC3000 “mitigation” update.

1 Like

If you’re flashing locally you can download your firmware binary from the build IDE (the little cloud button), or with the cli with spark compile your_source_dir and spark flash firmware your_firmware.bin


I have also had this problem, except it only happens when I flash certain code. I can reproduce this issue by setting some variables to certain values in code that runs fine otherwise.

It does not appear to depend on the state of the network.

Can you share how to replicate the issue?

I’ll be so happy to test it! :smiley:

Hahah, I’ll bet you would be! I went to replicate the issue this morning and was unable to, meaning it was some issue with the core talking to the network, although the web IDE was still able to indicate “Flash successful” and the flashing magenta lights started.

I’m thinking the core should have flashed green and then red, if it couldn’t talk to the network? The issue seemed to be very intermittent, and my internet service, streaming, etc. appeared uninterrupted.

Also, this was with the Message Torch code by luz in the projects section. Coincidentally, apparently, I was seeing the issue every time I set mode = mode_off, or when I set lamp_red,green,blue each to 0. This morning, however, it worked perfectly =]