Fast blinking cyan photon

I got a new photon last week. I had some problems to add it to my list of devices. Searching on forums I foun that I had to update the firmware, and do some other things to get it to my list. At the end I got it working. The version I have now is 0.5.3.

Today I tried to upload some sketches and I see that it takes about 30-40 seconds (sometimes more) since green light goes off and cyan start breathing. All this time is taken by a cyan light blinking very fast.

I read something about updating keys. I tried:

$ particle keys doctor your_device_id
It worked or at least that says my ubuntu terminal. Also new keys were sent to particle cloud.

But the problem persists. And it is very anoying that each time I upload a new code, I have to wait about a minute before I can start testing.

The other 3 photons and I have and the ones a friend has (about 3-4 more) work fine.

Does the issue happen when you flash an empty app?

I have tried with 3 apps. The simplest one of them just makes D7 pin to blink. But no empty app in my tests.

I can confirm the same behavior on two of my photons. Must be a DoS of some sort? - Fw 0.5.3 and 0.6.0-rc2.
Sometimes, my photons take a really long time to connect, sometimes connect all at once. Mostly 30-60s of rapid cyan flashes.

Thank you @mihaigalos. Then it may not be a problem of my photon. I thought it was broken or something like that.

I’ll keep an open mind, although it is highly unlikely that with three independent setups we (coincidentally) have the same result.

Have you verified the system firmware version on your Photon? If not, please try the following:

  1. Put your device in listening mode (flashing blue).
  2. Connect to it using a serial terminal (I like CoolTerm or Putty)
  3. Send the single letter v. What response do you get?

I get, as I said, 0.6.0-rc2. in the putty terminal.

I figured you might, given you explictly called out the system firmware. You’ve done both a

particle keys server

and a

particle keys doctor <device Id>?

I don’t have the dfu-util installed and cannot execute the aforementioned commands. What strikes me as odd is the my devices connect, after a certain time. At the next reflash, same rapid cyan flashing behavior. Sometimes they connect at once. So it’s completely random / asynchronous.

EDIT Even after having been connected, sometimes the devices lose connectivity and begin flashing cyan again.

I’m having the same problem. My Photons used to connect instantly, today they started behaving similar to yours. They blink rapidly in cyan for around 15 seconds, then they do a red blink, then they go back to rapid cyan blinking. After a couple of cycles they finally do connect.

Since this happens with two of my photons, running different software, that both worked fine yesterday, I assume this must be a problem with the particle cloud. Is there a status page or similar somewhere? Would be nice to get an official response…

1 Like

Having the same problem here. It connects after a while but it used to be nearly instantaneous. Maybe Particle is rolling out some new server side changes that are effecting this?

1 Like

Same here. My Photons also were having trouble connecting yesterday and the day before (11/17 and 11/18). I got the same LED pattern that @jakob described (my devices are running 0.5.3).

1 Like

There is a status page

But it doesn’t report any issues.
If there is something going on on the Particle side, we I can tag them to chime in.

1 Like

Thanks for the heads-up folks. AFAIK everything looks fine on our end, but if several of you are seeing this, then it’s definitely worth looking into. I’ll dig into the server logs and metrics for a few minutes and report back here.


Now thats some prompt response! Thanks for looking into this!!!

1 Like

There aren’t any big problems, but the device service instances are a bit unbalanced, as in lots of devices connecting to some instances with others serving very few devices. This might cause the behavior y’all are seeing. We’re trying to nudge them to rebalance. Connection performance should get back to normal soon.

Thanks again for letting us know!


I’m having the exact same issue. Has this been resolved on other people’s devices?

Wow! I go out for a few hours and when I get back there are lots of responses. Then it is a problem related to cloud side, so I am not breaking my photons haha

1 Like

Cloud justice has been applied. Connection speed and stability should be back to normal folks.