Blinks cyan or white for a minute or so then a burst of yellow

I am new to the photon. I have been searching the forum for the last 4-5 days trying to get this thing to work. I have purchased two of them and one worked no problem right out of the box. The OTA did not work at first so I was downloading bins and manually uploading. So I have CLI installed, I also have dfu-util installed and went through the ringer to get openssl installed.

I now have one photon that blinks cyan rapidly and does shorts burst of yellow every minute or so. The web ide tells me it cannot compile the canned code for blinking and LED or even just the base template.

It never has appeared online either in the build or in CLI. Initially the Web ide did not even say what firmware it was running. I used these commands dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D system-part1-0.4.4-photon.bin
dfu-util -d 2b04:d006 -a 0 -s 0x8060000:leave -D system-part2-0.4.4-photon.bin and then it registered 0.4.4 on the web ide. I have also done several variations of the keys doctor commands before and after the above firmware flash.

I am pretty much at my wits end.

My next guesses were read DTC dump or interrogate it with bus pirate.

Any advice. It is a really slick device btw.


So you are seeing blinking cyan with occasional yellow? That sounds like bad keys.

Can you do this:

  • Place the Photon in Listening mode
  • Use CLI and run the command particle serial identify to retrieve the deviceid
  • particle keys new junk
  • particle keys send insert_device_id_here
  • reset the Photon
1 Like

OUTSTANDING!!! That seems to have fixed it.I reset and got the breathing cyan. I flashed the blink demo via the web ide and shazam it works.

Thank you sooooooo much!!!

Here is the responses from each of the commands starting with the second one for others reference.

(…new junk)
running openssl genrsa -out junk.pem 1024
running openssl rsa -in junk.pem -pubout -out
running openssl rsa -in junk.pem -outform DER -out junk.der
New Key Created!

attempting to add a new public key for device device_ID_was_here
submitting public key succeeded!