Help with blinking cyan issue; exhausted suggestions from troubleshooting docs

I have the blinking cyan issue. I’ve tried a manual firmware reset and a public key reset. I still have the same problem. I can:

  1. put the device in listening mode
  2. connect to it from the Particle mobile app
  3. get as far as adding wifi password
  4. device appears to get as far as the “verifying ownership” step, and then it fails OR sometimes it complains that the phone can’t disconnect from the device

What’s next?

One other piece of info: when I tried the public key reset, it got to the last step and then said “Please provide a filename for your device’s public key ending in .pub.pem”. The command I had typed was particle keys send as it said in the instructions. Also I verified that the file actually existed in the directory. Just to be sure, I also tried particle keys send ./ also with the same result.

Any info on what causes this mode? Thanks!

The blinking cyan has nothing to do with keys - this would be the orange burst issue :wink:
Do you see an orange burst?

Blinking cyan is most likely caused by your device not being able to connect to your WiFi.
What encryption are you using?
Have you checked the network requirements?
Can you try supplying the WiFi credentials via a serial monitor or CLI particle serial wifi (don’t scan for networks if you want to be sure)?

Nevermind. I figured it out.

The public key reset worked, however, these instructions leave out the part where you need the Device ID before you run particle keys send DEVICEID

In order to get the key reset to work, here are the steps:

  1. Download cloud_public.der (
  2. cd into the directory where you downloaded this file
  3. Make sure the dfu-util package is installed: brew install dfu-util
  4. Make sure the CLI is installed
  5. Put the Photon in listening mode
  6. Type particle identify on the command line. Copy the device ID that is displayed.
  7. Put the photon in DFU mode
  8. From the command line run the following:
  9. particle keys server cloud_public.der
  10. particle keys new photon
  11. particle keys load photon.der
  12. particle keys send [device ID from step 6]

Once I did this, I was able to re-claim the device and re-flash my firmware onto it.



Thank you!!! Been stuck on this issue for a few hours and you’ve really helped me to fix it!

THANK YOU Morphatic