ERROR: No response from NCP

I am getting the following error running a simple helloWorld project.

0000011656 [ncp.esp32.client] ERROR: No response from NCP
0000011656 [net.esp32ncp] ERROR: Failed to initialize wifi NCP client: -210

Looking at other posts, I have tried the online Device Restore Tool, even setting the Device OS back to 1.4.4.

Post the restore, I simply get

0000011622 [hal] ERROR: No response from NCP

Is it fair to assume the modem has bricked itself?

You should probably get a full log using the Web Device Doctor but generally if that message is repeated continuously, it's often TAN004.

Also Device Restore USB should never restore your device to version 1.4.4 unless you select it in the popup menu. Were you using a different tool?

If you did downgrade to 1.4.4 and did not follow the instructions at the bottom of the device restore page, and you are using a device with a SARA-R410M modem, and previously had 2.0.0 or later, it can appear that the modem has failed, but it's really a baud rate mismatch.

Sorry. I said modem, but I really meant the ESP32 wifi radio (as this is an argon). The restore to 1.4.4 was in a another post on No response from NCP that Colleen had replied to.

Running the Web Device Doctor, I still get

0000000475 [system.nm] INFO: State changed: DISABLED -> IFACE_DOWN
0000002349 [app] INFO: Auto-connect disabled
0000003015 [app] INFO: doing wifiScan
0000003018 [app] INFO: Doing Wi-fi scan
0000011847 [ncp.esp32.client] ERROR: No response from NCP
0000011848 [net.esp32ncp] ERROR: Failed to initialize wifi NCP client: -210
0000011849 [app] INFO: wiFiScan resultCount=-210
0000018010 [system.listen] INFO: Entering listening mode
0000023334 [ncp.esp32.client] ERROR: No response from NCP
0000023334 [net.esp32ncp] ERROR: Failed to initialize wifi NCP client: -210

Sorry, the log indeed says esp32, it's just so rare it never even occurred me to check.

That almost certainly is a failure of the ESP32.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.