Electron not going into DFU Mode


#1

I’m having trouble putting an Electron into DFU Mode. I’ve tried following the procedure on Particle Tutorials to no avail. Right now the Electron is flashing blue. It also periodically flashes red for a second.

I’ve tried everything from restarting the Electron to flashing new bootloaders. I can identify it over serial and it’s on firmware version 1.4.4. Maybe I’m just missing a crucial step, but I think I’ve done everything.

EDIT: I should also note that after flashing for blue for a while it switches to flashing green, then back again after a while.


#2

Is this really (dark) blue or is it more like cyan?
Can you post a video (~30sec) of the flashing with the red flashes?
Can you also provide a video of the process where you try to put the device into DFU Mode?
With the verbal description I’d think it’s a keys issue but a video may clarify.

There are other options to put a device into DFU Mode too

  • by setting the baudrate of the USB serial connection to 14400 from the host side
  • with the command particle usb dfu

Once you got into DFU Mode you could try these commands to renew your keys

particle keys doctor <yourDeviceID>
particle keys server

#3

I have found on some devices that I need to use a tool to push the buttons as it seems that sometimes my fingers touch other pins/components nearby and it doesn’t work