Electron breathing magenta

It seems I can’t successfully load application software to (at least) one of my Electrons using Particle Dev. It keeps breathing magenta after the app flashes unless I flash it with Tinker. I’ve even tried my “doNothing” app and get the same results. Is there ever a need to update Particle Dev or does it merely get updated due to the fact that it’s compiling and linking in the cloud?

This is a bit new for me, as I’ve been successfully working both with Photons and Electrons quite a bit.

(update)By the way, a “particle identify” indicates the Electron is running 0.5.2

I would make sure you are compiling your user software against same version (0.5.2) and further that you have targeted an Electron. If you flash an incompatible user program to a device, it will enter safe just as you described.

Maybe trying the do nothing code from the web IDE to see what it does would be a good test. In the web IDE you can select which firmware version and of course device to compile against.

1 Like

Have a look at this topic to see a neat explanation of Safe Mode :smile:

Try a particle update while in DFU mode :slight_smile:


@bko, I used build.particle.io to compile and flash and it works fine. It also indicates the Electron currently has 0.5.2, the same as indicated with “particle identify”. However, if I try to compile and flash with Particle Dev, I continue to get the breathing magenta situation. I have done “particle update” a couple times while in DFU mode.

I’m still confused and assume Particle Dev will compile using 0.5.2 by default. Right? I am running 1.16.0 of the CLI (does that make a difference?). While on the issue of version, it would be handy if “particle help” listed the --version option.

Hi @ctmorrison

I think 0.5.3 is the current default so as @Moors7 said, doing a particle update in DFU mode will bring your device from 0.5.2 to 0.5.3 and I think dev will work for you again.

1 Like

Hi @bko, I’ve done particle update several times (while in DFU mode) followed by particle identify (once in listening mode) and it continues to show 0.5.2 (not 0.5.3).

Hi @ctmorrison

Version 0.5.3 was made the default around 11 days ago, so before that 0.5.2 was the default.

There are a bunch of ways to get 0.5.3 on your device listed here:

I would try one of the other methods if the CLI does not update for you.

I believe the problem is that you have Particle CLI 1.16.0 which install 0.5.2.
You need to update the CLI to the latest 1.17.0 to get 0.5.3.

It’s not at all obvious that this is the case, but each system firmware version has a different CLI version. The CLI doesn’t automatically install “the latest”, it just seems that way if your CLI is up-to-date.

The mapping is:

v1.17.0 = 0.5.3
v1.16.0 = required to recognize system part 3 of electron
v1.15.0 = 0.5.2
v1.14.2 = 0.5.1
v1.12.0 = 0.5.0


Hi @rickkas7, How do I update the CLI? I’m sorry, but I must be getting tired and have forgotten.

On a separate note, how can I tell what version Particle Dev is targeting?

Depending on how you installed it in the first place:
the CLI installer: https://www.particle.io/products/development-tools/particle-command-line-interface
or npm update particle-cli.

Particle Dev is currently unable to show, nor change, the currently targeted version. This is something that’s being worked on and will hopefully improve in the not-too-distant future :smile:


@rickkas7, @Moors7 and @bko, I think we have it…finally.

FWIW, perhaps I missed a post, but I’ve been chugging along developing code for Photons and Electrons and all of a sudden last Friday I started to get the breathing magenta issue. I’ve wasted quite a few hours on this. I’m very pleased with the Particle platform, but would have been extremely frustrated if folks like you weren’t amazingly readily available to help. I think something needs to change to make the resolution of this type of issue more obvious.

As always, I’m very appreciative of all the support.

Two more questions before I leave this issue fade…where do I see what issues are addresses/resolved in each system firmware update and can I do Photon system firmware updates OTA? I have a few that are “acting up” and I’m wondering if flashing new system firmware might help.


Hi @ctmorrison

See the releases page I pointed you to early to see what is in each release:

You can indeed update a Photon system firmware over-the-air and that is what the web IDE does by default when you select a release to build against, plus all of the other ways are listed with instructions on the releases page referenced above.

Just a heads-up: you have to down in a special way if you ever need to.

@bko, Thanks…I started looking down the list and got kinda lost. I appreciate your feedback!

1 Like