Particle Electron enters 'Safe Mode' ALWAYS

Hi all,

Just an FYI: I never make a post without actually putting the effort in first. This is always a last resort, as not to bother you all!

I’ve recently come across an issue with my Particle Electron. Ever since flashing ‘Tinker’ to it, OTA via my iPhone app, the Electron has been acting up.

The tinker app worked fine, and I could see some inputs and also light the on-board LED etc.

However, I uploaded some of my own firmware after, via DFU (also tried with Serial) - the Electron does it’s usual Green Flash >Rapid Blue sequence to connect up to the cell, but then it Breathes Magenta (Safe Mode)!

I thought at first that my code may have been buggy, so I uploaded the classic ‘blink’ sketch, with the same results. I’ve checked the firmware on my Electron, and updated it via the CLI, to 0.5.3 (which it was already on). I do all of my compiling in the Particle Dev editor.

With not many ideas left, I uploaded an empty sketch (i.e. empty setup and loop statements) and the same still happens - as soon as the Particle connects to the cell, it enters safe mode.

TLDR: My Electron enters safe mode, regardless of the codebase. HELP!!!

You might be getting the issue of having the user firmware compiled against a higher system version (> 0.5.3). There’s some issue with Dev for this but i can’t recall if it’s resolved.

Can you try using and flash an app to see how things so?

I think you’re encountering the problem described in the section “Electron flashes magenta after uploading binary” in this post. There are two easy solutions to the problem described there.

Thanks all. It was in fact an out-of-date firmware issue. I’d assumed when I ran ‘particle update’ in the CLI it would update to 0.6.0, but there we go :slight_smile:

Thank you both.

1 Like

It should do if you’ve got the most recent CLI installed.

1 Like