Particle Dev Issue - Electron

My Particle Dev cloud compile and download is resulting in a slow magenta blinking.
I undid all the code changes and even went back to the “blink.ino” example, and sure enough, same thing. Tried OTA FW upgrade using Particle Dev, and still no good. Then, I tried the Particle Build online and did an OTA firmware upgrade and it (“blink.ino”) works.
This points to a potential and sudden issue with the Particle Dev’s cloud compile. I didn’t even know it was different than the Particle Build’s compile mechanism.
Anyone else having this issue?

A new release of Particle System Firmware, 0.5.2, was released today. This is particularly relevant if you use Particle Dev (Atom IDE) and an Electron:

Particle Dev always builds against the latest system firmware release. This means that a program you build can run on that version, or theoretically a later version, but never an earlier version. So any program just built on Particle Dev will require 0.5.2 or later.

With the Photon this wasn’t an issue because the Photon would automatically update itself to system firmware to 0.5.2 when you installed a program that required it. It’s referred to as the safe mode healer.

With the Electron, this safe mode healer is turned off because it could cause a large usage of cellular data. Instead, you just go into safe mode, blinking magenta.

With Particle Build (web IDE), the default is to build against the version of the firmware installed on the device you’re building for. So, for example, if you had 0.5.1 on your Electron, it would build for 0.5.1. There’s also a popup menu to manually configure it. This is why Particle Build worked.

With Particle CLI cloud compile, you can choose which version of the system firmware to build against from the command line.

The easiest solution is to upgrade your Electron system firmware to 0.5.2 over USB. Or you can use the Build or CLI compilers.


Thanks, greatly appreciate it! I had a suspicion, because Particle build showed an option for 0.5.2. Glad to know that Particle Dev builds using the latest version. Having said that I was looking to upgrade to 0.5.2, but could not find the particle firmware manager that has 0.5.2. Is it just a matter of time before they publish it? How would I use CLI to compile for 0.5.1? I could certainly search on line for it, but figured I spent enough time already on google today.

I’m not sure about the Firmware Manager build, but to upgrade using the CLI, you typically put the Electron in DFU mode (blinking yellow) and then do:

npm update -g particle-cli
particle update

(Mac/Linux users may need to use sudo for the npm command)

To CLI compile for a specific system version, you use the --target option:

particle compile electron --target 0.5.1 my_project

1 Like