Electron boot loader

Hi all.

due to battery drain my electron lost the boot loader, no RGB led, etc … I have tried the norwegian blue without success always getting:
Do you have a dead device and wish to continue? [y,N]:y
SWD Fault error
Please double check the wiring, then try again.
which I did many times.

the programmer device is a 2G electron, system firmware 0.6.0. And I also tried 0.5.3, without success.

Any help would be greatly appreciated to recover the “dead” electron.


@sharly09 what’s the status of the LED?

Does it blink or no light at all?

Did you double check the wiring for norwegian blue just to be sure?

hi @kennethlimcp

Thank you for your help. I checked the wiring, the resistor (10k), …
the RGB on the dead electron does not light at all, only the D7 is blue

thank you.

Is it connected to D7 and 3V3 for the 10k resistor and you have 5 jumper cables?

Cos it says SWD Fault error which means the software didn’t run successfully.

yes, the 10k resistor connects D7 and 3V3 and all five jumpers.

When I look at the source code, it seems not to be able ro readplatformID (which should be 10 for electron

@rickkas7 might be able to help here and arrange for replacement if deemed necessary.

@kennethlimcp thank you.

Actually, this is the second electron I have in this situation after battery drain. So I am not necessary looking for replacement (although that would be appreciated) but more for a procedure to recover the dead electrons.

Any way, thank you for your help.

@sharly09 I’m definitely curious to inspect deeper into the issue.

However, i didn’t get my electron into this state and have no access to RMAed devices.

Can you describe the hardware setup and firmware running so that I can replicate it when my electron arrives?

@kennethlimcp here are the details

I am using this user firmware https://github.com/m-mcgowan/embedded-swd;

The setup is as described in Particle Programmer Diagram.png, with 2G electrons instead of photons, and two bread board as electrons do not fit on one breadboard.

The programmer electron system firmware is 0.6.0

The embedded-swd firmware is compiled with “particle compile electron . --target 0.6.0” and flashed on the programmer electron

The target electron is in D7 dim blue, RGB led does not light.

The target electron came into that state after running for 4 or 5 days with a battery fully charged and a solar panel (https://www.seeedstudio.com/0.5W-Solar-Panel-55x70-p-632.html), which was limited as it rained a lot.

Thank you so much.

A safe way back to a working device usually lead through a JTAG programmer and this FAQ