Electron total code erase & died

I wanted to update the system firmware of my electron and started out with the particle update command.
However, somewhere along the way, there was an error (see output below). After this error, I have the led on D7 on always and the led of the battery is still working, but the RGB led is always off and the Electron appears to be dead. @mdma Is there a way I can load the firmware back into the electron again so it can start working again. The df utility is useless at this point since I can not put the Electron in DFU mode any more.

$sudo particle update

> Your device is ready for a system update.
> This process should take about 30 seconds. Here goes!

! An error occurred while attempting to update the system firmware of your device:

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

dfu-util: Error during special command "ERASE_PAGE" get_status

> Please visit our community forums for help with this error:

Can you unplug the Lipo battery and plug in the USB cable and see if the electron boots up?

@kennethlimcp I already tried this, it has exactly the same result (except that the red led for the Lipo battery is always on instead of blinking).

@mdma I’d like to ping this topic again… We faced this with two devices now so it seems to be maybe larger problem? Any way to fix and prevent from happening again?

Do you have any details on what was happening with the device before it got erased?

In my case, I was upgrading the electron firmware by the CLI. Really happy to have finaly Some repelt on the topic! It would be geest to be able to erflast the electron again!!! In my case it was a 2G model but unfortunately we had it with a 3G model as well.

@mdma Do you have any news on this already?

No, I’m sorry, there’s not much to go on. As I’m sure you can appreciate, many folks upgrade their firmware every day and we’re not seeing the problem. Of course, I realise it’s very real, but it must involve more than just a firmware update. Was the device connected to the battery, left unattended?

@mdma, I understand you do not have found the origin of the problem yet, but maybe you can already help us with a way to refresh the electrons so that we can use them again. That would already be GREAT

Hi @GrtVHecke

If your D7 LED is on dimly and the main RGB LED does not light up at all, you are probably in a “no firmware” state. Your device can be made to work again with the help of a JTAG programmer or perhaps another Particle device acting as such.

Do you have a JTAG programmer like the ST-Link or the Particle Programmer Shield?

@bko and @mdma, yes I have a Particle Programmer Shield. Can you guys point me out to the instructions I need to use to reflash the Electron (2G model in this case and also for the 3G model).

This could be due to faulty power. Basically in our case the problem was most likely caused by external watchdog which triggered during the programming part. @GrtVHecke were you using battery while programming?

@tuxie, @mdma, @bko, at the time of the “accident”, the Electron was powered by an external power supply, but it had the battery attached.
@tuxie, were you able to reprogram the Electron? If so, please can you point me to the procedure who to do this? Thank you!

Our developer was able to reprogram with JTAG programmer.

@tuxie, can you please point me out on how to do that? Thank you!

Haven’t done it myself so don’t know excatly. Most likely you’ll need the binaries for electron and then jtag programmer from STLink for example and then just upload the binaries via the programmer. Most likely google can help a bit more.

@GrtVHecke, maybe this will provide some useful hints, till one of the Particle peeps can chime in

especially this section

and the binaries can be downloaded from here

This might help with the bootloader

Have you opened a Support Ticket already?

1 Like