Electron bricked - solid D7 led

electron
Tags: #<Tag:0x00007f1ca6decc80>

#1

Hi everyone,
my Electron stopped working this morning and now only D7 led is on when I turn it on with its LiPo battery. When I plug it with the USB cable, the usb led also turns on.
I can’t understand why It stopped since I’ve been using this configuration for months. I read about it may be due to flaky power supply or bad contact though and that’s probably my case since some sensors’ leds flickered a bit.

I can’t get into DFU mode anymore and I also tried holding SETUP + pushing reset one time, as I read in another thread.

I also tried SWD using a Photon as programmer. I run it 10/15min ago but it didn’t prompt anything except for:
Do you have a dead device and wish to continue? [y,N]:y
Photon’s led is solid yellow/red while their D7 led are brighter now. Can I stop them?

I went to this topic (Dim d7 blue light and jtag config help for recovery) but links there are dead. @ScruffR

Can I use other photon as JTAG programmer? If not I have also a MCS-73 TTL USART and a chinese board I used as TTL/UART but with many more pins available (In the picture. HD: https://ibb.co/cQYzywL)

Can somebody help me? Tnks :slight_smile:


#2

There might be an issue with how you power the Electron
See here
https://docs.particle.io/datasheets/cellular/electron-datasheet/#3v3-pin

If if that was possible, the power demand of the Electron would max out the power the Photon could provide via the 3v3 pin and potentially damage the Photon’s regulator

https://docs.particle.io/datasheets/wi-fi/photon-datasheet/#pin-description


#3

Damn, I moved the jumper from Electron’s 3V3 to its VIN. (Opposite side).
I relaunched SWD but I don’t see any difference from before. Just blue leds are not so bright now.
Too late?


#4

Possible :flushed:

What does the Photon do now when you take it out?
What does the Electron do when you plug in the LiPo (and nothing else)?


#5

Photo starts with blue (MAIN) led on.
Electron only turns on D7 led as before.

Nothing has changed. I think my first topic is still valid then :sweat_smile:


#6

You can file a support ticket at support.particle.io