Reviving a bricked photon using electron and SWD?

Hello,

My photon stopped working after an OTA flash that didn’t go as planned.
It shows a solid D7 led, no RGB led at all, doesn’t respond to attempts to DFU or safe mode.

I read in a few posts here about https://github.com/m-mcgowan/embedded-swd.
I have a spark core, a photon, and an electron.
The photon is bricked so I wanted to do it from the core or the electron but it didn’t seem to work correctly.
When I tried to use the web IDE to flash it to the core it didn’t compile.
So I downloaded the .bin file from the releases section for the electron, and flashed it via usb.
Then I tried to connect via screen /dev/cu.usbmodel1234 9600 but nothing is displayed and it isn’t responding to any key press.
I also tried the serial tool in the particle dev app - same results (nothing’s printed or responds).

The electron starts with a breathing white RGB, that changes to a blinking blue after a few seconds.
Running particle serial list returns the electron successfully.

I don’t have JTAG.

What can I do ??
Is my photon lost for ever ?

Thank you.

How exactly

particle flash --serial norwegian_blue_electron.bin
// or
particle flash --usb norwegian_blue_electron.bin

I’d advise for the latter and what’s the output of that?

What’s the output of particle serial inspect before and after the flash?

3 Likes

WOW!!
That was insane!!
It worked!

Thank you very much!!!

I’m quite shocked it actually worked and I got my photon back!!!

3 Likes