Disappointing start [SOLVED]

So excited when the Spark Core arrived at my doorstop!

Ran the Spark App on my Android…wait wait…fail…

Did a factory reset and tried again…fail.

Had to logon to my router and check the settings to see if the b/g/n was affecting…didnt worked

Wanted to try out the TI smart config with an open network without encryption hoping that logging on the SSID was the culprit… Turns out that for Android app, you need to register in order to download and still have to sideload it.

Manually upgrading the CC3300 flash is also too much for a disappointing start.

Hi @kennethlimcp,

I’d be happy to help you get going with your core. When you say “fail”, can you describe the lights you’re seeing? What model Android phone are you using, and what wifi router you’re using, etc. It sounds like you probably don’t need to upgrade anything on your core, but if that’s too much please feel free to email me at david@spark.io and we can figure out another solution.

Based on your post, it sounds like you’re running a unencrypted wifi network. We posted an update to the android app store last night that addresses this issue, can you try with that version and let me know if smart config works? https://play.google.com/store/apps/details?id=io.spark.core.android&hl=en

Thanks,
David

Hi @Dave,

Thanks for your prompt reponse!

  1. The Core was able to receive the UDP packets as it turned from blinking Blue to Flashing Green
  2. Im using Samsung S4, Android 4.3
  3. My router is from my ISP…a Huawei but dont have the model with me now.
  4. My SSID is on WEP, Open, 64bit, Auto Channel, 802.11b/g.

Thanks once again :smile:

Hey @kennethlimcp,

It sounds like you’re running into the WEP issue other users have been seeing on the community. We have a “configure over serial” fix checked into the firmware that we’re going to merge into our build server and hopefully our factory update sometime today. You can also grab this firmware directly and flash it right away if you want https://github.com/spark/core-firmware/blob/master/build/core-firmware.bin (You just need dfu-util on your system: https://github.com/spark/core-firmware#3-device-firmware-upgrade-utilities ).

With that fix, you can configure over serial http://docs.spark.io/#/connect/connecting-your-core-connect-over-usb , and just select WEP encryption. WEP is a tricky security protocol, and some access points might require you to type your password in hex versus other encodings.

Some users have also seen issues with channels above 11 for some reason, so if you’re using a router from outside the U.S. try a lower channel to see if that helps.

Thanks!
David

1 Like

Hi @Dave,

Thanks for all the information! This WEP information should be in the Troubleshooting guide.

I decided to try using another SSID with WPA-PSK, AES and managed to get the core connected to the cloud swiftly.

That was before i even did a firmware upgrade you advised.

I tested the Channel issue as well. Works fine only for channel below 11

Hope this verification on WEP issue being the problem would help get more cores connected successfully!

Need more information about firmware upgrade OTA:

  1. How can we tell that our Core has been upgraded to the latest firmware pushed via the cloud?

  2. Understand from the Doc that “Flashing magenta: Updating to the newest firmware” is that right?

  3. When will the firmware be pushed OTA? Meaning once the core is turned on and connected to the cloud?

Thanks for the great support so far. I did beta testing for LEGO in the past and the skills might come in handy to help catch some bugs…

Wishing all a joyful festive season! ~a little Spark Core blinking away in Singapore ^^

Hi @kennethlimcp,

Thank you for posting your findings!

1.) Right now your core will only update automatically to the last release of tinker when you connect to the cloud after a factory reset (or after leaving the factory ). I know down the road we have some fun features planned that will expand on this, but in the meantime maybe this is a good question for @zachary , our API expert. :slight_smile:

2.) Flashing Magenta on your core indicates that it’s receiving firmware from the cloud, yup! Each flash represents a packet of firmware. About half-way through the process (the D7 led will come on ) and the flashes then signify the core is moving firmware around and getting ready to reset. This way in case something went wrong, your core can fail back to good working firmware. It takes a little longer, but it’s way safer.

3.) Right now we’re not queuing over the air firmware updates, but we are working on automatic update features. Again, maybe @zachary our CTO can chime in.

Thanks!
David