Dim D7 LED and no other lights

I have the same problem with my photon, what i can do?

So you can’t get into either safe mode, nor DFU mode?

Yes, i can’t

If you have another device (Core/Photon/P1/Electron) you could try this - https://github.com/m-mcgowan/embedded-swd

It’s still in beta but it can be used to revive devices. This will try to fix things so that you can get into DFU mode.

1 Like

Yes i have an electron and a core too i will try

I would try on the electron first, since that’s also a STM32F2 device.

i tried it and my electron and photon just turn more intensive D7 led

What was the output - did the tool report success?

Nope, the response was SWD fail and ask me if i have right the connection of the pins

do you have another method to solve my problem?

Do you have a dead device and wish to continue? [y,N]:y
SWD Fault error

This happened to mine yesterday. Any idea what caused it? I just bought a brand new photon loaded up my program and moved to garage for my door opener project.

Most cases this is caused by some flaky power supply or bad contact that led to some “brownout” condition.
The root cause and how to prevent it is still not completely clear.

1 Like

Power supply might explain my issue. It has now claimed two photons. If it is power related is there any hope for recovery? I through out the first one. But the second one is still on my desk, I am still in shock of losing within six hours of getting in the mail.

You don’t need to throw out the device. It may be recoverd by reflashing the corrupted areas.

Since you got another Photon you could try this

1 Like

The photon is broken. I do have a Spark, but I can’t get the SWD to flash.

I just got one photon with the same behaviour. L7 on, everything else off.

It was working on a programmer board and as soon as I removed from it (all off, then re plug in), this happened.

Anything I can do apart from throw it away? In mine, when I press setup and reset and release the reset button, I see the status led blinks (3 colors, very dim) for less than a second.

Do I have to do something before trying to use them as usual if I am using them for debugging?

@mdma I am stuck in this situation as well. I have a very dim D7. I set up everything according to the embedded-swd repo and I get this output:

Do you have a dead device and wish to continue? [y,N]:y
SWD Fault error
Please double check the wiring, then try again.

and then the LED on my programmer turns orange

I checked the wiring with the diagram in the repo and it matches exactly with what I have. Not sure where I’m going wrong here

I’m having the same issue and I’m fairly certain that it was caused by overvoltage spike on the 3v3 line. I just ordered a new one because I really need it for a project. I’m hoping this one might still be salvageable though.

My case is peculiar in many ways. I’m going to explain here what I did to my Photon so that it’s clear to anyone that might try to help.

  1. The device seemed to work nicely from the box and I was able to connect to a Wifi. I also flashed my own program through the IDE.

  2. While testing, I connected the 5V power to a current-regulated supply where (I think) the current limit was too low which caused the input level to drop low. This is what I think made the device break the first time.
    I googled around and after some diagnostics was able to conclude that the problem was most with a burned regulator. So I removed it. With this the device worked nicely through the 3,3V input.

  3. I soldered the Photon unto a PCB. On the pcb I had planned to have a 5V rail as an input so I had to figure something out. I decided to try connecting the +5 input and the 3,3V input, since on the schematic I couldn’t find an issue with this. When I got home and tried to connect it to work in a different area, the device blinked green indefinitely signaling that it was looking for the connection. It seemed to be working fine until I tried to move into listening mode. I couldn’t switch to the listening mode. DFU worked. I was quite puzzled

  4. My puzzlement was cut short when I accidentally applied about 8 Volts on the 3v3 line. This is where I am currently and the only thing happening when I power the device is that the D7 led lights up. I’ve gone through the basic commands with the buttons and theres no response at all.

From what I understand, the D7 led lighting up and no action on the RGB might be a sign of an emptied bootloader. Can someone confirm this? I’m really just asking if I should give this more time and effort. Please point me in the right direction if possible.

That alone was a bad idea - this pin is marked 3v3 for good reason.
Also the docs do warn from applying more than 3.3V

The 3v3 line is directly connected to the supply pins of the µC and that is a 3.3V device

Thanks for the reply. I do understand the ratings on the pins and I did take a good look at them after having already screwed up once. I wrote the reply late at night in a hurry and I didn’t mention that I supplied only regulated 3,3 volts on the combined input(before I accidentally bypassed the regulator).

As far as I was able to understand the 5V line is only connected to the board via the onboard regulator(which I removed.) That is why I figured just connecting it to the 3V3 input might work.
From the photon datasheet:

I’m fairly certain that either the Wi-Fi module or the µC is fried now due to the overvoltage applied straight to their input. I might take a closer look at diagnosing the problem later.

1 Like