Photon unresponsive, steady blue light

So today I found my Photon completely non-functional. The only thing showing is a steady blue light on the user LED off to the side. The main multi-color LED between the two buttons is off. I tried power-cycling, a different USB cable, etc. but every time I power it up, the small blue LED lights up and nothing else. I tried pressing various combinations of both buttons but nothing happens. Also, when I plug it into my laptop, it’s not making the usual “USB device connected” sound.

How do I get this thing going again?

Any idea how your device got there?
There are some threads about dim blue which usually tell you’d need to reflash the core firmware and bootloader.
For this you’d need a hardware programmer (even another Photon could be used)

This is my Sparkfun Weathershield Photon. Apparently, a connection to the solar panel came loose and the battery ran down.

The USB factory reset method won’t work because I can’t get the Photon into listening mode by pressing the button. But I found this thread: Using the example app to Revive a Dead Device. I actually do have another (working) (so far) Photon so I’ll give the method described there a try. We’ll see…

1 Like

OK, so I connected the two Photons together as directed in the “Revive a dead device” page and ran the programmer app. It asked me if I wanted to continue and I said “y”. Then it instantly popped up: > “SWD Fault error, Please double check the wiring, then try again”

Well I double, triple, and quadruple checked the wiring and all five wires are going exactly where the directions indicate: 3v3 - 3v3, GND - GND on both sides, D6 - D6 and D7 - D7, plus a 10K resistor from 3V3 to D7 on the programmer Photon.

The little LED by D7 is on bright blue on both devices, the multi-color LED on the dead device is still off and the one on the live device is on steady orange. I tried power cycling and running the programmer again but got the same result. I ran it once more and this time it went “Not sure about that. Do you have a dead device and wish to continue?” I said “y” and then it went back to the “SMD fault error”.

Now what???

In that case you may need to open a support ticket and ask for a replacement device - unless @mdma has an idea why his tool bails out.

I notice that several other people had the identical problem and the same “wiring error” message in this thread: Dim D7 LED and no other lights` but no resolution for them either. I even verified jumper continuity by checking the resistance directly between the corresponding source and target pins, right on the header solder connections, in case I had a bad jumper wire or breadboard clip. Everything’s connected. There’s no “wiring error”.

Sigh - I guess it’s support ticket time, though I’d really rather get this one running again if possible.

The other option - for future instances of this - would be to get a Programmer Shield.

Hey there @Michele – thanks for your patience…we’ll make sure to get the issue sorted out as soon as possible for you. @BDub is ramping up our investigation of these symptoms, and we hope to have a root cause issue identified in the next couple of weeks.

Well many thanks to everyone who offered help with this problem and major kudos to Particle staff. I sent in a support request yesterday afternoon, on a Saturday, and had a reply in less than two hours that a new Photon would be going out to me on Monday. That’s what I call super customer service!

Meanwhile as long as I already have my one remaining good Photon stuck on the breadboard, I will use the time to implement a battery voltage monitor to help keep this from happening again.


Do you mean something like this? Pocket AVR Programmer That might be interesting to play with, especially since Particle doesn’t want the dead Photon back.

Actually I meant this one

Alternatively you could get an ST-LINK/V2

I see - thanks!