Dim d7 blue light and jtag config help for recovery

im struggling with dim d7 led light
any can help with a detailed step by step jtag process
( the one in faqs does not cover all config settings )


Don’t know what jtag is, but with this code snippet you can control the Photon RGB LED - I´m on the right way (I know this differs to D7)?

void setup:

void loop:
RGB.color(255, 0 ,0);
RGB.color(0, 255, 0);
RGB.color(0, 0, 255);

That won’t help a lot. When calling for JTAG with the dim D7 issue, the device is in a state where you need to get a bit more hard core :wink:
@Lagartus, have you seen this already

But before reflashing your device, could you pull a dump file?

@mdma @BDub
im working on it.

im confused on this.
a- at startup the address is 0x08004000 or 0x08000000 ?
b- size 0x8000
c- data 8 bits

conection settings:
jtag or swd ?


then read out memory protection

ive tried to change the level to 0 with the same error


@BDub is the guy to ask for the details (or maybe @mdma)

@Lagartus I’m going to ping @rickkas7 here and see if he will guide your through the process for your device (btw, which type of device is it?)

thanks for your help
its a photon

Are you using ST-LINK for Windows or openocd? I presume ST-LINK.

0x08000000 is the address for programming the boot loader, which is what you need to update for Dim D7.

0x08040000 is the address for the viewing configuration. You don’t need to change the settings (Address, Size and Data Width) as those are for viewing data, and you’re going to be programming it instead.

Instead you want to use the Program and Verify menu item in the Target menu. It’s the next picture in the FAQ.


Did start a fresh procedure
Followed instructions
Stopped here
Cannot disable read out protection

Please help @rickkas7

If you’ve tried to set the Option Bytes settings, Read Out Protection to Level 0 and an error occurs, it usually means the processor can’t be recovered, unfortunately.

The most common cause is damaging the processor with high voltage or ESD, but it could happen for other reasons as well.

Thanks for your help
Its says that protected (option bytes)
The wierd thing is the photon was never connected , only usb
I will send it to be exchanged then

Thanks again for your time