Photon recovery using JTAG, "Cannot read memory"

Hello all,
I have this exact problem discussed here with 2 of my photons now, dim D7 LED and no RGB. I accidently gave 14V to the Photon for an instant to the first one some months ago and now a friend of mine switched VCC and GND.

Luckily I have an ST-Link V2 Mini clone with me and the Partcile Jtag FAQ says: “One symptom of a corrupted boot loader is the Photon/Electron only has a dim D7 LED and doesn’t respond to any other buttons. And the main LED does not light.” So I followed the steps to reflash the bootloader using SWD and I’m getting “Can not read memory! Disable Read Out Protection and retry.” in the ST Utility software on Windows 7 64bit. This thread here discussed the same and has a possible fix but in my case, it does not allow me to change “Read Out Protection” to 0.

Also, I think this thread here discusses some solution but I could not follow exactly where all those commands were put…
I tried connecting while holding Reset and using the “Connect under Reset” option, neither worked, memory could not be read.

I’ve been debugging this for the whole day today, and I know that’s not a lot by debugging standards but I need a working Photon by Monday, so I headed here immediately for assistance. Any advice would be appreciated.

Here is a picture of the programmer connected:

Have you considered that either of those actions can permanently ‘kill’ your device, with no way to recover it?

I initially had, but reading some posts on the forum, I have hope that it can be revived and it’s just the bootloader which is corrupt. And the JTAG utility successfully recognizes the processor, isn’t that a good sign?:sweat_smile: :disappointed_relieved:

if the flash software gives a force option i would try that. my understanding is the software ignores all warnings and just performs the flash. if the only warning is what you mention and it can not be fixed a force option should just flash.

I don’t see any force flash option. When I flash the bootloader file, it says “Do you want to disable read out protection and continue?”, but then that doesn’t work, “Cannot disable read out protection!”.