Difficulty creating a Webhook for RPi Server: Integration Creation Failed error

Hi Folks,

I’m trying to create a Webhook to transfer data from my Electron board to a RPi server, running TIG stack. I’m trying to follow this Tutorial:

https://docs.particle.io/tutorials/integrations/influxdata/

I try and create the webhook in the Console using mt RPi IP address, in the following format

http://<my_IP_address>:1619

But get the following error:

“Integration creation failed: url must use a valid protocol and not reference private hostnames”

Can anyone shed some light on the reason for this error? And what is the correct workaround to get a Webhook sending data to my Pi?

Thanks :slight_smile:

Is <my_IP_address> a public address?

2 Likes

Good question, I’d not considered that, being new to all this.

No, I don’t think the IP address I’ve used is public. Reading this seems I can use this to find out my routers external IP address

curl icanhazip.com

Might need to configure my router too. I’ll see how I get on. Any other tips for setting up the webhook welcome though.Thanks.

Yes, you need to use the public address of your router and configure port forwarding to your RPi - after that you should be fine.

1 Like

Right, I’ve made some nice progress but hit another setback.

I’ve created the Webhook in the particle console using the correct IP address:

http://<my_IP_address>:1619

Telegraf is setup to listen on port 1619, and seems to be running fine: ‘Started the webhooks service on :1619’.

I’ve configured by router for port forwarding on port 1619.

Logs in the particle console say Webhook triggered. Good news. But then gives

‘Error Status 404 from <my_IP_address>’
and ‘Sleeping, too many errors, please wait and try again’

Presume it can’t get a reply from my server.

Any thoughts most welcome.

Thanks.