Debug errors using Debugger hardware with Electron

Hello,

Just getting started with using the hardware board: Debugger with my electron. Can someone point me to the solution to clear my issues under PROBLEMS/DEBUG console. I’m a novice at this stuff, not sure whats going on. Sequence of events:

  1. Connected debugger to USB and Electron board via documentation
  2. I did do a clean application for debugger
  3. Started debugger and consistently get these 5 problems.

those look to be intellisense errors. are you able to compile your firmware with issue? if so, here’s the intellisense troubleshooting guide:

Thanks for responding!

My code can compile/flash (locally) with no issues. However and maybe this is a cockpit error on me but the debugger does not seem to work. E.G. I would simply do a break point and do a restart on the debug console (upper middle menu) expecting it to break but it brings up another file?? There is still a learning curve but I’m not getting a good feeling its working correctly.

I’m still not able to debug at all. What else could be wrong

Hi @KB1DC, the debug function looks worked in the picture. The errors you posted are something related to the PATH setting.

Can you please try:

  1. Create a new project with a simple application e.g. blink and try the debug function?
  2. If the debug function works in the simple application, you can pack the problematic application to us.
  3. If it still doesn’t work with the simple application, please record a video, that would be helpful.

also @KB1DC here’s the info we need to help troubleshoot:

in particular, running the Particle: Audit Environment with your project open is very helpful.

Thanks so much. Will try your recommendation