Intellisense: Report Issues Here


#1

hello particle workbench user :wave:

as you’ve no doubt learned, intellisense can be a bit finicky - it’ll flag non-issues in the “Problems” tab, report missing headers, etc. rest assured, if your code compiles you can ignore intellisense’s errors.

still, that’s not a UX we’re happy with so help us track down any lingering issues by reporting them here :+1:

before posting, here are some trouble-shooting steps you can try to get things back in shape as well as instructions on what info to include in your report should your issue(s) persist:

  1. confirm you are working within a Particle project created via the Particle: Create Project command
  2. close and re-open your project
  3. close and re-open VSCode
  4. run the C/C++: Reset Intellisense Database command (ctrl/cmd+shift+p, then start typing the command name)
  5. try adding "C_Cpp.loggingLevel": "Debug" to your project’s ./vscode/settings.json file (or use VSCode’s UI - File > Preferences > Settings then search for “logging level”)
  6. with logging level set to “Debug”, select the “C/C++” entry in the Output panel’s drop-down menu (top-right next to the panel’s “close” button), open your .ino / .cpp, and share the log it produces.
  7. run the Particle: Audit Environment command and share the non-sensitive parts
  8. share the C_Cpp entries from settings.json in your project and user settings
  9. verify that your project settings.json includes "C_Cpp.default.configurationProvider": "particle.particle-vscode-core"
  10. create a minimal .ino or .cpp file that reproduces your error (or if you are comfortable sharing, a link to a .zip file of your entire project)

after each step, verify that you are still seeing inaccurate issues in the “Problems” tab within VSCode.

see here for instructions on how to open your settings.json files:

once again, thanks for trying Workbench :pray::+1:


Can't compile because of 'particle::SPISettings' and make errors
[ISSUE] Intellisense does not recognize pinReadFast()
[ISSUE] Intellisense problem
Error: "Configure your Intellisense settings to help find missing headers" (was: Arduino extension required?)
pinned #2