D7 keeps giving a timed out error

The D7 port seems to not be working on my core. On Tinker I get a pop up message that says “Core Pin Timed out.”

When I tried triggering it with PHP on a html form, it also give me a timed out error.

What can be the issue?

What code are you using? Still the default Tinker firmware, or have you flashed something yourself? If so, would you mind sharing that code?

I fixed it. I just restarted the core and it started working again. Any common reasons why this would happen in the first place?

That’s hard to tell without knowing what code was/is running. I can’t think of a reason why it would randomly stop working, without there being an error of some sorts.

Hello Moors7,
Thank you for helping me previously with getting connected to my core (another thread). I don’t mean to hijack this thread but I had the same issue with out of the box code from tinker (the default “blink an led with tinker”). I did what joshbocanegra did with his…restarted the core and it started to work. This might be a question and comment -> "maybe a good idea to simply restart the core after any changes to code?"

Sounds like a WiFi issue to me. Do these cores have the CC3000 patch?

@BilboBaggins saving changes to your code in the web IDE won’t change that code on your core, you will need to flash (lightning bolt button, above saving) that code to ‘save’ those changes on your core.