Unable to flash core, only get 500 error

I have a Spark core that I am trying to use again, but I have lots of problems trying to flash. I see it is has the glowing LED, but I hit flash on web-ide and I get a 500 timeout. Is this indicative of server load, or is there something wrong with my core locally?
Thanks.

A factory reset often helps, if you’re willing to give that a try.

I’ve been experiencing same issues . I have tried a factory reset a ready with no luck. I’ll try to test it out again soon and see if I’m still having the same problems.

Just following up on my previous post - I did a factory reset and I am still getting the same 500 error when I try to upload via the web IDE. I was able to upload code find this morning.

Also, after the factory reset I believe Tinker should be loaded automatically. The iOS particle app is telling me that my device is not running Tinker. I attempted to flash Tinker from within the app but I also get a 500 request failed error.

CptanPanic any luck on your end? I think the issues might be related. I was able to load code this morning without a problem.

Yes I did a factory reset, and it seemed to help. I’m guessing maybe my code was transmitting too much data or something.

Perhaps due to a known server issue (http://status.particle.io/):

Build farm had a brief partial outage
We discovered one of our build farm workers ran out of memory, and was unable to perform builds for some time this afternoon. We’ll be adding alerts to catch this earlier, and working to identify the source issue this week. Should be back up and happy now. Thanks!
Jul 26, 17:47 CDT

Another thing I was thinking was how does how much work you do, or a delay() in the loop() bother the flashing process?

I got home ready to keep working and still not able to flash :frowning:

So currently I have to try flash like 5 times to finally get it to work. One thing i notice, it is seems to knock the Core offline when I hit the flash button.

I used to have this problem when my loop() lacked a sufficient delay (>1sec). If that’s the case you can add SPARK_WLAN_Loop(); at the end to allow for a flash to occur. The few times I left those out it would take me a half dozen tries to get the timing just right for the flash to work, it was always easier after a reset though.