Core v1 Setup Issues

I received a Core years ago at a developer conference, and I recently found it during a move. I’ve got a project in mind that I think it’d be perfect for, but I can’t seem to get it up and running.

I can manage to connect it to my Windows machine via USB, and here have been my results with various commands trying to get it working:

(after putting it in DFU mode)
particle flash --usb tinker

Flash success!

Device resets and goes to blinking green.

particle serial wifi

? Should I scan for nearby Wi-Fi networks? Yes
! Something went wrong: Serial timed out while initially listening to device, please ensure device is in listening mode with particle usb start-listening

particle usb start-listening

▌ Getting device information...particle usb start-listening[50596]: c:\ws\src\node_api.cc:1087: Assertion `(func) != nullptr' failed.
 1: 00007FF78662363F napi_wrap+128063
 2: 00007FF7865C2836 v8::base::CPU::has_sse+35142
 3: 00007FF7865C2B53 v8::base::CPU::has_sse+35939
 4: 00007FF7865E74E5 napi_release_threadsafe_function+181
 5: 00007FFE7FC9CFF4
 6: 00007FFE7FCA0EA1
 7: 00007FFE7FCA0BF8
 8: 00007FF7865FC893 node::Stop+72595
 9: 00007FF786D8DBE0 v8::internal::Builtins::builtin_handle+323456
10: 00007FF786D8D127 v8::internal::Builtins::builtin_handle+320711
11: 00007FF786D8D468 v8::internal::Builtins::builtin_handle+321544
12: 00007FF786D8D26E v8::internal::Builtins::builtin_handle+321038
13: 00007FF787224EDD v8::internal::SetupIsolateDelegate::SetupHeap+546893
14: 00007FF7871A9D8C v8::internal::SetupIsolateDelegate::SetupHeap+42748
15: 00007FF7871A9D8C v8::internal::SetupIsolateDelegate::SetupHeap+42748
16: 00007FF7871F7F56 v8::internal::SetupIsolateDelegate::SetupHeap+362694
17: 00007FF7871A5443 v8::internal::SetupIsolateDelegate::SetupHeap+23987
18: 00007FF7872895C0 v8::internal::SetupIsolateDelegate::SetupHeap+958256
19: 00007FF7871A9D8C v8::internal::SetupIsolateDelegate::SetupHeap+42748
20: 00007FF7871A9D8C v8::internal::SetupIsolateDelegate::SetupHeap+42748
21: 00007FF7871A30BC v8::internal::SetupIsolateDelegate::SetupHeap+14892
22: 00007FF7871F9392 v8::internal::SetupIsolateDelegate::SetupHeap+367874
23: 00007FF7871C6F2D v8::internal::SetupIsolateDelegate::SetupHeap+161949
24: 00007FF7871A71AC v8::internal::SetupIsolateDelegate::SetupHeap+31516
25: 00007FF786CE7CC0 v8::internal::Execution::CallWasm+1536
26: 00007FF786CE7DB3 v8::internal::Execution::CallWasm+1779
27: 00007FF786CE8192 v8::internal::Execution::TryCall+354
28: 00007FF786CCA1A5 v8::internal::MicrotaskQueue::RunMicrotasks+501
29: 00007FF78663F8D1 node::CallbackScope::~CallbackScope+593
30: 00007FF78663F6EE node::CallbackScope::~CallbackScope+110
31: 00007FF78658AC9B v8::internal::Scope::locals+30875
32: 00007FF7865EA3D3 node::Start+275
33: 00007FF7864967AC RC4_options+339628
34: 00007FF7872DBE08 v8::internal::SetupIsolateDelegate::SetupHeap+1296248
35: 00007FFE964A7034 BaseThreadInitThunk+20
36: 00007FFE97502651 RtlUserThreadStart+33

I also tried particle flash --usb cc3000 and got:

Error writing firmware: file does not exist and no known app found. tried: `cc3000`

And that’s as far as I can get. Any help would be greatly appreciated. Thanks in advance!

Just in case anyone in the future finds this, it turns out that running
particle doctor
worked perfectly. Case closed!