Connecting to hidden SSID network [SOLVED]

I have been searching the forum, but could not find a definit answer/solution for this aparent problem.

I can connect fine to my WiFi network as long the SSID is broadcast, but recently I tried hiding the SSID an as soon I did this the Cores can’t connect. They just keep flashing green “forever” till they eventually go into blue blinking.

On the other hand, when I force one of my other devices (e.g. tablet PC) to disconnect and reconnect to the network while the Cores are blinking green, I might get lucky and one of the Cores may “see” this and kick into the network, too.

Is there a way to make the Cores trying to connect to hidden SSIDs - by themselves?

I looked this up and see one line where TI patched hidden ssid issue with a specific router.

IOP Fixed Connection issues to TP-LINK WR740N in hidden SSID mode, with security WPA2+AES, and SSID length is larger than 8 characters

Not sure what firmware version our CC3000 module is on and whether the soon to come CFOD patch will include this but seems like connecting to hidden SSID is possible.

http://processors.wiki.ti.com/index.php/CC3000_Release_Notes

Will test it tonight!

@zachary? Answers please? :smiley:

Interesting. So, for that matter, is there even access on the Sparkcore board to the CC3000 for updating its firmware? I haven’t seen anything in the docs, so far.

The CC3000-patch-programmer (see in github) does the job :smile:

Freshly made cores are also loaded with the patch and run the 1st time it connects to the cloud!

It’s definitely possible with a .bin file written to do so.

Thanks @kennethlimcp for looking this up and I’m eagerly waiting what more you’ll find out :+1:

There’s limited info online and @zachary knows best! :wink:

Meanwhile…I’ll do the test on my side :smiley:

EDIT:

@ScruffR, I did a hide ssid on my router and the core along with other devices got disconnected.

Once the configuration completed, the core connected back successfully! I did a reset and it still did.

To make it a fair test, i factory reset my core and sent wifi credentials over USB. wooola! breathing cyan :wink:

The joke is…my S4 did not connect back…as well as an iPhone…the core is beating them hands-down!

@ScruffR it sounds like this misbehavior might be on the router’s side, not the Core? What router make and model are you using? I am not familiar with the deep dark depths of 802.11 but I can’t imagine why connecting a device (your tablet) to the network would cause the Core to break through other than some odd behavior from the router.

1 Like

Thanks @zach & @kennethlimcp for your feedback and tests.
I am using a Netgear WPN824v2 and a Cisco EPC3925 both with SSID and PW known to both my Cores and found withing max. 15 seconds when SSID gets broadcast but not or only by chance found when hidden.

The thing with my tablet may well be a coincidental connection, but if I have no obvious traffic on the network the Cores don’t connect, but when I have traffic (esp. connect negotiation) it happens more often than not.

After @kennethlimcp 's report that it should work and @zach 's hint that it might have to do with misbehaving routers I reset my routers and started from scratch.

And found out that the Cisco works well as long the Netgear is off.
But at the place where I expected the Netgear to take over the signal strength of the Cisco was too weak to be picked up by the Cores, but when I had my tablet or phone produce traffic it seemed that the Cisco somehow boosts output power enabling the Cores to pick up - I guess :blush: ?? :question:

Once I activated the Netgear things did go downhill, since the tab/phone connected to it and the Cisco didn’t seem to boost - I guess again.

As a next step I updated the Netgear firmware, which didn’t really change anything.

After that I fiddled with the channel assignment on both routers (previously AUTO) to make sure the two routers don’t annoy eachother and after some dud combinations I found one that - maybe in combination with the FW update - seemed to have solved my problem.

Duh! - Soooo sorry for having not done all that beforehand - but I was not sure if the Cores were even meant to connect to hidden SSID. Once that was clear and the hint that actually the routers might be the root :wink: I knew what more to try.

So THANKS again :+1:

3 Likes