Configured and Claimed Spark via USB - now how do I link it to IPhone App?[SOLVED]

Dear All,

I managed to configure my Spark Core using USB and have claimed the Core in Build. It now “breathes” CYAN.
Following this I have tried to log into the app using my wifi name and password - the same wifi name and password that I used to configure the Spark Core - AND - the app says “No cores found”.

I can create new code using build and flash it to the Core using USB but if i’m not able to control using the app its no use right?

Any help will be appreciated.

Thanks
Baggins

1 Like

Try logging it with the same credentials you use for logging into the build IDE.

I did but the same response “No cores found”

I’m just a bit confused about that. You’re not supposed to log into the app by using your WiFi credentials, but rather your Spark.io account. Do your Cores show up in the web IDE?
Could you try logging in here to see if your Cores show up?

1 Like

Yes I see my Core when I login to my Spark.io account.
On the App I am already logged into my account.
There’s a button on my app that says connect to core - when I click on this button it asks for SSID and Password.
The SSID automatically populates with the wifi account my phone is using … I enter my wifi password and THAT is when the “No Cores Found” message pops up.

That button is there if you want to connect your Core to your network, using the app. If you’ve already configured the credentials over USB, then there shouldn’t be a need to do that any more. In the top left, you’ll be able to open a menu. Once you click that, you should get an overview of your Cores. If you select one of those, then you should be able to control their pins, provided the default Tinker firmware is still on the Core.

You are right. It has been connected all along. Thank you very much for your help. My problem (non-problem) is now solved :smile:

Regards

3 Likes