Compiler timed out or encountered an error


#21

Just tried again, and it worked. Do you see the logs now?


#22

Yes, I see the logs now. And they’re weird. It’s building the file with the guid in it, but it doesn’t seem to be building foo.ino, and then it seems to hang when it calls arm-none-eabi-gcc-ar to make the archive file. I’ve never seen it do that before.

To rule out even more stuff, maybe trying with the simplest program possible in foo.ino would make sense:

void setup() {
}
void loop() {
}

Very strange!


#23

Done. See anything different?

I do end up with a .bin file. I did the last time around, too.

BTW - the .cpp file is completely empty. I assumed that was your expectation.

Jason


#24

Sorry, I had the wrong filtering set on the logging. The build looks completely normal from the build farm side now.

Starts at May 10 15:43:49, ends at May 10 15:43:52 EDT, so it’s definitely running quickly enough. And it’s generating what looks to be a valid firmware binary file.

I have no idea why Particle Dev is saying it timed out, but it really does look like it’s working from the compile farm side.


#25

The last two compiles have not timed-out. So, I it makes sense that the most recent compile looks good.

But this is the first time it has worked in about a week. If I see another timeout failure, I’ll re-compile this test project and see what you can find from your end.

Thank you for the prompt support today!


#26

@peekay123 - Thanks for the guidance regarding the Particle.variable(). It’s my first time playing with Particle’s Cloud Functions.

Agreed on the delay structure, as well. I am just trying to get a simple pipe-cleaner working for test IFTTT and Google Cloud Platform integrations.

Thanks!
J


#27

I am getting this error very consistently with a particular set of code. I had it compiling very nicely yesterday, then did some evolution on it, and now the problem happens every time. I go back and compile the earlier code just fine.

There are no significant changes to the size or structure of the code, just some refactoring. The error happens on both a Mac and and Windows 10 PC.

Suggestions would be very welcome.
Thanks,
Doug


#28

I’m having a nearly identical situation today, as well.

I have two sets of code that function perfectly, and when I combined them today I got the “Compiler timed out…” error.

I am able to dial the commented code up and down and variably get Success! and that error with no clear pattern on specific code being commented out or even size of code.

Maybe there’s actually something server-side going on?

Thanks,
Bill


#29

OK. This is weird. The program compiles fine with this line as part of it:

Blynk.virtualWrite(V6,String(bestTune));

But fails with the time out error when it is replaced with this line:

Blynk.virtualWrite(V6,String(sensor.getCalibration()));

More information: it turns out that getCalibration() was defined in the .h file but I had not done the actual code for it in the .cpp file. When I created the member function in the .cpp all was well.

Yeah, it is something on the server side. Perhaps the linker is not reporting errors properly?

– Doug


#30

That seems likely. I’ve tried commenting/uncommenting and when I have a situation that would cause an error, I get the timed out message. It does seem like maybe it’s not reporting errors properly.


#31

I am pretty well convinced that this error is caused by the linker not being able to find some external. While the error is seriously misleading and uninformative, at least I can work with it. I love the Particle processors, but I’m real tired of wrestling with the tools.
– Doug


#32

Hello, was this ever solved as I am getting the same compile error message using Desktop IDE. When I use the Web IDE I the whole process just timesout.

Very frustrating.

Andy


#33

I suggest you look for code that calls a function that you have not implemented. This could be simple spelling errors in the reference or definition, or mis-matched arguments on member functions. It could also be external variables that have not been defined. Ever one of the times I have seen this error, I have run it down to one of those. I’d be interested in hearing about any other cases.
– Doug


#34

I went simple with the following, and still got the same message

void setup() {
}
void loop() {
}


#35

I have now manage to verify and upload code via WebIDE but desktop IDE (cut n paste of code) verify/upload still getting the same error.


#36

@rickkas7 are you able to help out here again?


#37

Which error are you getting with the Particle Dev (Atom desktop IDE)? Build didn’t produce binary or compile timed out?

Try adding a file 7df1e3a5-ed01-4847-bb05-0e5d1d646b99.cpp to your build, doing a build, and let me know. That randomly named file is so I can find out which build is yours in the compile farm logs so I can see what actually is happening.

And here are some general tips as well:

Rick


#38

I noticed recently that if I had an error in my code, I would get the “Compiler timed out or encountered an error” message. I discovered that if I changed the build target, errors were again reported.
The following build targets reported errors ok:
0.6.1-rc.1, 0.6.0-rc.2, 0.6.0-rc.1, 0.5.3, 0.5.3-rc.3, 0.5.3-rc.2, 0.5.3-rc.1, 0.5.2, 0.5.1, 0.5.0, 0.4.9, 0.4.7, 0.4.6, 0.4.5, 0.4.4, 0.4.3, 0.4.1
The rest result in the Compiler timed out message!

I even went as far as creating a new Particle account, installing Particle Dev on a different computer & logging in with the new account. This yielded exactly the same results as before!

I also checked with a friend and he is experiencing the same problem.

This code is all it takes to reproduce the problem:

int test // no semicolon so we generate an error!

void setup() {
}

void loop() {
}

Windows 10 (Version 1703, OS Build 15063.296)
Particle Dev (Latest version of Windows ParticleDevSetup.exe available for download)
Photon (Firmware Version 0.6.2)


#39

Load .cpp file as requested.

I have also moved the file to a stand alone folder as in the tips (i didnt know this). However, I can compile and upload from the CLI.

Andy


#40

I just ported the Talkie library and it’s exhibiting this behavior. If you try to compile an example sketch (e.g. _1_Getting_Started.ino) in Particle Dev you get “Compiler timed out or encountered an error” 100% of the time. If you compile using either CLI or build.particle.io, it works fine.