Compiler timed out or encountered an error


#1

I am using the local IDE and all used to be fine. Recently however I started getting the above message. Four out of five times I try to compile! This is not making getting things working easy as it is a lottery as to whether the code will actually compile or not.

I am on a good connection so I am pretty sure it is not my network or the computer itself. That leaves you guys, do you have a problem with your system? If not have you go any idea what is causing this to happen?

When it does actually compile things are fine.

Many thanks in advance for any help.


#2

@tre4b, can you give a time frame of that happening so that the engineers can take a look at the logs?

@bryce @jvanier


#3

Hi Ken, Most of last night (UK time) 2200 to 1100 should be loads then again 0730 ish this morning.


#4

We didn’t see issues with the compiler service last night. I’ll see if @suda has ideas since you say this is with the Desktop IDE.


#5

@jvanier, I have noticed compile times seem much longer with 0.6.1 than prior versions. Is/was that expected?


#6

Thanks for letting us know. I don’t think it’s related to the firmware version. I’ll check internally the health of the compile service.


#7

+1. having the same issue. using core 0.6.1.
sometimes it flashes on the first try, other times it take 5-10 tries where it times out.


#8

I am getting the same error for simple interfacing program


#9

Hi,

Has there been any updates to this issue? I am seeing the same problem very consistently.

I prefer to use the desktop IDE; however, if there are some known issues causing this compile problem, I will switch to the cloud IDE.

Thanks!
Jason


#10

@jasonpecor,

how many lines of code roughly do you have in your project?


#11

Hi Kenneth,

Sorry for the delayed response.

The compiler issue seems to be completely unrelated to how many lines of code there are in the file. For example, I tried again this morning with a very simple and short 10-line program. It’ still hangs up.

From a user perspective, it seems to be a problem related to communicating with the cloud compile service - not a program file issue.

Does this help?

Thanks!
Jason


#12

@jasonpecor,

@rickkas7 will be able to get a Particle engineer to look into the logs and see what happened.

Let’s see what he says.


#13

Excellent. Thank you!

Jason


#14

I can check the logs. Just add a file to your project named 7cc36407-c593-41c3-beb6-6455bcf2c714.cpp so I can find which build is yours. Just build your project until it fails, then stop building and let me know and I’ll check the last build with that file in it.


#15

@jasonpecor, note that Particle.variable() needs to be declared only once in setup() and not called repeatedly in loop(). In the Particle.publish() line, you are missing the TTL argument:

Particle.publish("data-updated", 60, PRIVATE);

You may also want to not block loop() by using a millis() delay, like this:

unsigned long delayIt = 0;

void loop() {
  if (millis() - delayIt >= 10000) {  // This will start after 10secs from reset
    delayIt = millis();
    data = random(100, 500);
    Particle.publish("data-updated", 60, PRIVATE);
  }
}

#16

Done. Failed on the first attempt.


#17

Interesting. I can’t find the unique file in the build logs, so it appears to be timing out before it gets to the build farm. Are you able to hit other API endpoints from Dev? Like is the Device selector working?


#18

Yes, I can see and select online devices.

I want to make sure I am including the cpp file in the build correctly. I am relatively new to your tool.

Will it automatically compile all files in the project directory when I compile?


#19

Yes, but there are some weird caveats. This is my compilation of handy tips for Particle Dev:


#20

Great link. Thanks!

I closed the open tabs and compiled again. Here’s what my project folder looks like: