Cloud IDE Library reference and WebIDE breaks constantly!

So i’m back working in the cloud as i haven’t downloaded the alpha of the Workbench to do my mesh testing.
Things I keep running into.

Libraries… can’t just use include statements, must find them, then tell the cloud ide to add to a project, where it then puts in the .h reference even if its already there… annoying, but ok.

However, I found that libraries don’t support the new devices getting things like “Platform should be Core or Photon”. Fine… removed library. Compile without Library include, and remvoed from IDE side bar. Still get compile errors!

Also get constat 404 errors, random slow responses from the Cloud, etc. My internet is rock solid, can do anything else on the internet, so not likely my connection issue. Sometimes won’t work until I shutdown all browsers and go back into the IDE. :frowning: very frustrating!

The Web IDE definitely has it’s ‘quirks’. For a more solid approach, you might do well to download the Workbench IDE. That also gives you some more control over your files, and their management.
The Web IDE is due for an overhaul, no doubt about that.

1 Like

well, hopefully they make the Workbench IDE rock solid first :), thanks.

That won’t change with Workbench either.
In fact I can’t imagine any IDE where this wouldn’t be the case :wink:
Even IDEs that come with a boatload of pre-installed libraries (e.g. Arduino IDE) don’t have each and every library on-board but may need to acquire that first too. On the other hand, having hundreds of libraries you’d never use seems a bit of a waste too.

Libraries are contributed by individuals that may not be aware of their library not working or just didn’t find the time to update them yet.
If the library has a GitHub repo linked you could file an issue there or just post on this forum about it and maybe the contributor or someone else may be willing to update the library.
But we’d need to know which

I’m currently also experiencing some slow builds with Web IDE. This may indicate some server side issue which I already reported - but that’s not what we usually see.

3 Likes

WebIDE just started to not display any existing projects - this is a big worry as I have invested a lot of time and effort. I have tried refreshing the cache, logging out and back in to the browser, using another browser. Every time it just displays https://build.particle.io/build/new as though there are no files stored any longer? :frowning: Any community ideas as to what is happening? [Update] I left the browser/webIDE open for a while and eventually it loaded the apps [big relief]. This now means I need to backup everything locally, so probably move to using workbench IDE on VSC. Is there an easy way to copy all the webIDE app to github or download to local files?

@armor, the only backup method is to manually download the zip (containing your code) for each app you have in the IDE.

image

2 Likes

Thanks - I got a bit of a shock earlier - what do you think about the stability of the workbench IDE? I am worried about using it before it is at least a good beta version.

VS Code is not really beta. It is a well established IDE and as such no big troubles are to be expected from that side.
The only “quirks” I have encountered with Particle Workbench were about comfort or UX (e.g. IntelliSense, multiple steps for one task, but they were rapidly solved - some users reported issues during setup, I never had any of that).
I never had a stability issue with it.

OK - maybe I need to jump in and invest my time in getting it setup then. Thanks for your viewpoint.

1 Like

@armor, I am still getting used to the Workspace thing but otherwise it is working well. I am still learning about “complex” libraries with subfolders, etc but no show stoppers so far. With the latest release, I am able to use the new Particle debugger from Workbench. I think the biggest “pain” is having to do a “compile clean” when I change from one platform to another (eg. Argon to Xenon). This is also required if you use the local toolchain anyway. I would absolutely recommend using it.

2 Likes

I’ve been using the VS with Workbench/particle add-on. Much Much better than the web IDE, please Particle.io keep up the work and get it finalized!

1 Like

@peekay123 - Any suggestions on how to get up to speed with the details of libraries such as you mention? I’ve been liking workbench a lot, but this is the one thing that keeps tripping me up. I went looking for documentation on Workbench, but it appears to still be a TO DO item.

What in particular are you wanting to know?

I had a longer response in here, but I’ve come to the conclusion that my question should really be a separate post over in the Workbench category.