Is there an up to date guide for the IDE?

I have been searching for examples to set up DS1820 project and each document I view shows different IDE features to what I have.
For instance, the WEB IDE has no “Open” icon on left, I can only remove an “app” or create a new “app”. I have several icons missing compared to the online tutorials page views.

Also, When I attempt to add any libraries to a project they are never installed properly and I have to manually find the library files on my drive and copy them to my project.The tutorials show being able to add the library to your existing project but I get different options like “View”, Git and “Use”. When I click “Use” I see dialogs saying the library was installed but when I attempt to access it, I get no such file error.

Thanks

Regards

Dave

Are you looking at the Web IDE docs or Particle Dev?
Web IDE never had and still hasn’t got an Open icon because it’s not file based.

Properly imported libraries won’t have their files in tabs on the Web IDE either.

These “View” and “Use” buttons only exist in Particle Dev (aka Desktop IDE)

Thanks for your response,
I am new to particle and finding the library handling a bit confusing.
I have tried both the WEB IDE and Particle Dev. My preference is Particle Dev.
Would you mind explaining the best way to add these libraries to the project without getting the file not found errors?
Do I always need to manually find the files and copy them into my project folder? I would have hoped when I wanted to “USE” a library that it would place the files where they can be found in my project and I just add the #include and compile.

I noticed the libraries did get downloaded and placed into a folder in documents/particle/community/library
Most libraries had the “cpp” file and “h” file as well as a sub directory with repeated “h” file
I was not sure what I needed so I copied all the files from main folder to my project and then the sub folder to my project and managed to get it to run. But this seems a cumbersome/manual way to handle libraries.

It would be great if libraries were placed in the main particle dev root and then simply #include <xxx.h> instead of needing these manually placed into every project folder. The idea of libraries for me is to reuse them over and again, a common repository makes most sense to me.

Thanks

Regards

Dave

1 Like

Currently we are somewhat in Limbo with the new libraries structure and the recently reworked Arduino compatibility features.
Particle is aware of this and they are looking for a way out of that.

For the time being, if you experience issues with a library targeting 0.6.1 firmware, you can try to target 0.6.0.
If this doesn’t help either, the library contributor should be informed via a GitHub issue on his repo to migrate and re-publish his library.
If he doesn’t respond in due time, let us know about that and Particle can re-assign ownership to someone else who is willing to take over maintenance of that lib.
Meanwhile you can download the source files of the lib from GitHub (or via copy/paste from Web IDE) and do the required alterations yourself.

About the use of the “USE” button look in this thread

For properly ported libraries you would just do USE + Add to current project.
This would only add a dependencies entry to your project.properties file and not download the sources at all.
If you explicitly want the sources downloaded to your project (e.g. to customise the library) you may use the Copy to current project feature.

Hi,
I do not want to customize the libraries or access their source, just use them in my project.

In this case do I just select USE + Add to current project and then I can #include the library and access it?

Or, do I still need to manually copy files around?

As a side comment, It has taken very little time to go from nothing yesterday to having an MQTT temperature node sending data to my Node-Red Raspberry pi dashboard, very happy with this and the over-air programming.

BTW: have you got any links to integrating particle with Grovestreams? I followed a grovestream tutorial to create a webhook. The log shows particle receives my temperature from the device but keep getting error 400 when it attempts to forward to Grovestreams. I not they use {{SPARK_CORE_ID}} style of parameters but wonder if this has changed or still valid? (I did try {{PARTICLE_CORE_ID}} but makes no difference.

An example of the settings of the webhook integration for a working example would be very helpful.

Thanks again,

regards Dave

1 Like

This is the console log showing error. I can see particle gets the temperature ok but not connecting with gs

@orbitcoms, Dave, I feel your pain. Is there any chance of a worked example in the form of a video or step by step for the new library addition/copy/use??? feature in particle dev?

Thanks :slight_smile:

This is how it’s supposed to work. No file copying required.
If it doesn’t it’s probably due to the libs current implementation.

I have no knowledge of a GroveStream library.
Is there an Arduino lib to look at?

@orbitcoms, I’m happy to help with your Grovestreams issue. I would need to see your webhook and your Particle.publish() that you’re using to send data to the webhook.

From the log screenshot, it certainly appears you’re not formatting the data properly in your publish.

1 Like

@orbitcoms, I have been playing a bit more with Dev and I found an issue with that I’ve now reported to Particle