Clearing Blinking Green on Argon after a year of being off

Sorry. This is a very newbie question. I received an Argon board at a seminar in 2019. During the 2 hour session I was able to claim my Argon board. I powered it up for the first time since August 2019 and got the blinking green. I can log in via web browser and see it has been claimed on my account showing last connection of August 2019. I can log in via the Particle app on my iPhone and it shows that it is one of my devices (same data). But it says it’s offline and it shows the IP as being the IP it got when I was in the seminar over a year ago. I’ve tried to re-add the Argon board and it fails. I set it to listen mode and it fails. I looked at my bluetooth settings and don’t see it broadcasting. So I see where the blinking green means it can’t get to the internet/can’t connect to the WIFI. But how do I get it to join to my home WIFI? Do I have to un-claim it then reclaim?

Dan

Hi Dan, and welcome to the community!

I think you need to reconfigure the WIFI settings in the Argon. In order to do that, you can download the Particle app on your mobile phone.
Then you set the Argon in listening mode, by pressing the MODE button onboard until the LED blinks deep blue (few seconds).
Then on the app you tap on the + button -> setup an Argon, Boron or Xenon
You then scan the sticker of your Argon with your phone

If it finds that is already in your account (I think it will), you select Switch to Control Panel:

Once there, you can follow on screen instructions to configure your home wifi:

Let us know how it goes, please!
Gustavo.

Thanks for the quick reply. I hope to learn a lot from the community

The reason I have posted this I tried all the things your reply says. It fails and it says to contact support. So, that’s why I have posted this. I’m trying to get past the failure.

Have you also tried to wipe any preexisting WiFi credentials from the device (by holding MODE for 10+ seconds till it starts blinking blue rapidly)?
Also, have you attached the WiFi antenna? Unlike the Photon the Argon does not feature an on-board WiFi antenna.

Also, do you remember whether you may ever have set a static IP address for that device? If so, you need to flash a new firmware that actively re-enables dynamic IP acquisition.

Here is what I’m seeing. I do have the antenna attached. I have held the mode button down to make it flash blue. How do I flash the firmware when I can’t connect to the board? I have more photos but I can only attached 2

Via USB and CLI

That way you can also setup WiFi credentials among other things.

I’m going down hill fast. I tried to install the CLI but it fails. I then managed to load DFU-Util but I have no clue as to how to get the latest firmware. I tried command /Users/myname/bin/particle ; login and it asks me for a login but I have no clue to which user name/pw I should be using. It might be cheaper to pay $30 for a new board

I managed to do a particle usb reset [devices…] [–all] and I was able to repair it. And it has a new wifi connection. So, not sure what I did right but it works.

Thanks

Dan

2 Likes