Argon stopped connecting to Wi-Fi flashing green

Hi Guys

After working 100% for a few months my Argon started flashing green. Normally when these disconnects from the network I simply add them again with the CLI particle serial Wi-Fi command.On this one no matter what I do it wont go past flashing green ‘searching for internet’

Here is what I tried :

  1. Various networks, different SSIDs (all 2.4Ghz). using CLI (I cant use the app as my QR code is wiped off)
  2. reload keys
  3. Reload all the firmware from scratch using jlink. (all the bin files) a processes im very familiar with (using both version 1.4.4 and 1.5.2)
  4. Reload tinker
  5. Erased all the old settings.
  6. Checked my antenna.
  7. Tried doctor (particle keys doctor) particle keys server.
  8. Particle update

anything else I can try.

I also flashed the code on other Argons and they all work. (not that that would make any difference)

Can you please try https://github.com/rickkas7/photon-clouddebug for the errant device to see whats up?

thanks @no1089 please see below output from serial port

:confused: That’s a first for an Argon that I’m seeing. It would seem the ESP32 is not responding to the NRF52840.

Can you please create a ticket at support.particle.io so we can organise you a replacement and figure out what went wrong. Please quote this discussion.

thank you. Must be ESP failure.