Cisco Model DPC3939

Problems with the Core connecting
I am gonna just throw out call for help and see if anyone can come to the rescue.

My client has Cisco Model DPC3939 from Comcast Xfinity.

I have gone through the settings with him, they are as follows.

  • 2.4GHz 802.11b/g/n (there is no b/g or legacy mode on this router, the choices are g/n or b/g/n) so far neither worked
  • security is WPA/WPA2-PSK (TKIP/AES)
  • Channel 11
  • 5GHz network is turned-off

I cannot get his core to connect using the Wi-Fi app… Is there any thing else I should / could try? I am kinda desperate here.


Try using Particle CLI and tell it the security type yourself. That got my first core online and then after that anytime I reset it has worked from the app. Let it update after it connects, will flash magenta, reboot…leave it be until it goes into a cyan breathing state.


I will need to have him return it so I can do the CLI. :grimacing:

I guess configuring via USB is not an option?

Is there a lot of traffic on the client’s wifi network? I’m not positive (maybe somebody at particle can elucidate), but due to the way that the Core’s (or really, the Broadcom SoC’s) Smart Config works, I imagine that high-traffic could cause the wifi setup to fail.

If possible, it might be worth trying the config at a time when you’re sure that the network is pretty quiet.

Walk him through it over the phone…very simple process really.

@dougal thanks, I don’t think it is problem. He is home alone at the moment.
@LukeUSMC I may have to… the know process is pretty easy, I just remember that installing node.js can be non-trivial.

Thanks to both of you.

If you should happen to have problems with node.js you’d only need any serial terminal (e.g. PuTTY).
If you can do it via TeamViewer or any other remote assistance program, you might safe on telephone time too :wink:

don’t I need node.js to run particle-cli?

Yes for CLI you do, but for setting up WiFi credentials and claiming the device, you don’t need CLI.

Cool, is there an how to on this that I missed?


Huh? That part of the docs seems to have vanished (got lost during the recent overhaul).

But in short, when putting your device into Listening Mode, it opens an USB serial port and listens to a few one-letter commands.
The most important are “w” for entering the WiFi credentials and “i” to get the device ID for claiming the device e.g. via Particle Build.

Thanks @ScruffR

And a thanks to all for the suggestions.

1 Like