Can't login - my account is broken and I'm dead in the water

So, I just added 2 Xenons to a mesh and suddenly only 4 of my 15 devices appear in the app. I logged out of the app and it won’t let me login.

The android app return retorfit.RetrofitError: 430 when I try to login

Opening the console in a browser just gives me a 404

CLI in Workbench: -

particle whoami - returns my email address.

particle list

  • Retrieving devices… ! Error in particle-cli:
    ! Cannot read property ‘error’ of undefined
    ! See C:\Users\xxxxxxxxxxx\AppData\Local\particle\error.log for more info.

https://login.particle.io/login - login or forgot password says: “Particle Server Error. Contact us at particle.support.io

…and logging a ticket gets me an email to say I’m not likely to get a response for 6 business days.

I’m dead in the water.

ping @mstanley @ParticleD

1 Like

…and I’m back!

Console now opens - app lets me log in and I can see all my devices.

CLI lists all devices.

So - what happened?

…and now it’s broken again.

Web pages (console) just 404.

Android app says “No devices found”.

CLI: particle list
/ Retrieving devices… ! Error in particle-cli:
! Cannot read property ‘error’ of undefined
! See C:\Users\xxxxx\AppData\Local\particle\error.log for more info.

Have the WEB IDE open - pressing “devices” gives me the list - but once refreshed, nothing appears.

Rebooted laptop and andriod tablet.

Workbench opens - but no Particle button. If I run cloud compile:

Compiling code for argon

Compile failed: Cannot read property ‘targets’ of undefined

Error: Command failed: C:\Users\PeteTheRanger.vscode\extensions\particle.particle-vscode-core-1.4.2\src\cli\bin\windows\amd64\particle.exe cloud compile argon --target 0.9.0

I’m getting this in the dev tools for chrome:
Access to XMLHttpRequest at 'https://api.particle.io/v1/user' from origin 'https://console.particle.io' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource.

And I’m getting this for the console pages…

Bummer! That’s not the page you’re looking for

But as long as you’re here - would you rather fight a shark with bear arms or a bear with sharks for arms?

(This was mildly amusing the first time… but now its just annoying…)

1 Like

Hi Pete,

Would you be able to provide the email address of your Particle account and a couple of example IDs in a private message with @ParticleD and myself? We’d like to look into this and see if we can’t figure out what’s going wrong here.

PM Sent - FYI: I’m able to login again now.

Working again now - I’ll leave it to @ParticleD and/or @mstanley to divulge the details of the problem and/or fix.

1 Like

Hi Pete,

Thanks for the update! After digging into this a bit, we made some changes on the backend that we believed to be the cause. It looks like it worked and this should be fixed now. But if you happen to notice anything come back up, feel free to post here and we can keep digging into it.

…just lost it again - same scenario - I was running the android app to add xenons to a mesh.

:cry::frowning::thinking:

@ParticleD and @mstanley - am I the only person with this issue or does it warrant changing the system status?

I just wonder if other people are out there banging their heads against a wall while there’s an underlying system/service problem that hasn’t been acknowledged/advertised yet.

Hi @PeteTheRanger / All,

Thank you for reporting the issues you’re experiencing. I know there were some changes today to how the API is load balanced, and I’ve forwarded this thread along to the team to investigate.

Thanks,
David

1 Like

Worked for about 30 minutes - now it’s out again.

Seems like if I touch the Android app to change a setup then it dies.

:thinking::face_with_symbols_over_mouth:

…I’d rather be able to work - (sorry, frustration…)

The GOOD NEWS is I’m off to Scotland for 4 weeks - I’m sure it will ll be fixed by the time I get back!

I’m getting the same thing but it seems to be linked to my home IP address. If I use the same laptop on a mobile hotspot it works as expected. I only have 5 Photons online and nothing is spamming the cloud. I tried restarting to clear any background tasks that could have been caused by Visual Studio Code. Just seems to be IP related.

I hear you fella - it seems a little odd. When I got back in I just decided to work on my code - flash, flash, flash… all OK. Thought it must be fixed - let’s do the “Set-up thing” and bang…

Unfortunately, very disruptive.

For the techo-boffins… I’m on a 25Mbps satellite link - really fast but a lot of latency. What’s your rig @JumpMaster?

Standard UK cable broadband. 200Mbps. I have a sticky IP address. It will only change if the router is off when DHCP renews which is every 7 days. So it never changes.

I’m getting the same error near Atlanta, GA US.