Can't connect Particle to 'open' wifi network that uses 'Accept' page

I’m in a bit of a bind because i have to demo on friday a Particle at an elementary school as part of a STEM program, and in testing their wifi network today to make sure things work, I can’t associate the particle to their network, I think because their network requires clicking an Accept button on a web page, much like you see at public networks in airports, etc.

So it’s open to guest usage in that it doesn’t have a passcode, but it has that dang button. I think the particle gets tripped up on that, that’s my best theory. The result is that in the IOS page where the Particle-XXXX network is, it goes back and forth between the circulating progress arrow, and the wifi/info symbol, never settling down, and never getting any confirmation. Is there any way around this? I would use my iphone’s hotspot but I doubt that will work and I can’t leave my phone behind anyway.


I’m afraid captive portals are not supported (as far as I’m aware). If it’s for a demo, perhaps you could ask the network administrator to set you up with a separate network if possible. Perhaps bring an old router of your own.
If that’s a guest network, then isn’t there a non-guest network with a plain old password? That be easier.

Actually, it does. Very well even. For demonstration purposes it’s ideal since you can configure everything in advance.

I used to have similar troubles and as @Moors7 said, there is no native support for Captive Portals like this.

But there are workarounds that did the trick for me.
Most CPs do allow for short connection losses by remembering your MAC address, so if you find a way to hook onto that network with one device that happens to have :sunglasses: the same MAC as your device.
With the Spark/Particle Core it was quite easy to alter the MAC to fit one of your devices (phone, computer, …), but I’ve no idea if and how this would be done on the Photon.
The other option - I usually choose - is with a rooted Android phone which allows me to spoof its MAC to fit my Particles MAC.