Can't connect or reset core is breathing light blue

I have never been able to use the app to connect (on iphone 5). I use telnet. I updated to the particle software and since then my core flashed light blue/white (cyan?) slowly. It isn’t in and the spark app just hangs on the “let’s connect your core screen” after I enter the wifi password.

It’s not flashing blue like wifi listening mode. It’s more like when your sketch is running.

When I try to use telnet doesn’t detect the core connected via usb.

When I try to reset it flashed yellow then white but just goes back to breathing cyan… I’ve tried different usb cords and plugs. I can’t get to listening mode. What should I try next?

Breathing cyan is just fine and once you’ve done a factory reset (blinking white), you have got the Tinker firmware running, which does not open a serial port via USB.
Although it’s odd that it can enter breathing cyan state after a factory reset.

If you want to put your Core into Listening mode manually, you don’t press the RST button but only hold down the MODE button (on an already powered Core) till the LED turns blue.

If you have issues with using your iPhone, it might be due to the fact that it tries to connect to 5GHz WiFi rather than 2.4GHz, but the Core can only connect to 2.4GHz.
Check if your router is set to use g/b only.

When I hold down mode it stops breathing and gets frozen on white. I thought it was supposed to go to listening after being factory reset?

I can use tinker with my other core, but it crashes when I click on the arrow to see the settings for the core.

Correct, it should go into listening after a factory reset.

It seems as if the FR does not really reset propperly.
Could you try to do multiple (3 or 4) FRs in a row before trying to do anything else to the Core?
Make sure to wait till the FR is completely done before doing a subsequent one.

Could you also try out CLI?

How was this done?

I thought the CLI said something about it. I have both spark and particle CLI neither works. Multiple factory resets didn’t work.

myMacintosh:~ futurebird$ particle serial list
No devices available via serial
myMacintosh:~ futurebird$ 
myMacintosh:~ futurebird$ particle setup
                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |
| .__/ \__,_|_|   \__|_|\___|_|\___(_)_|\___/

> Setup is easy! Let's get started...
> It appears as though you are already logged in as
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

> No devices detected via USB.
? Would you like to scan for nearby Photons in Wi-Fi setup mode? Yes

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You may lose your connection to the internet for a moment.

> No nearby Photons detected. Try the `particle help` command for more information.
? Would you like to wait and monitor for Photons entering setup mode? No

> Ok, bye! Don't forget `particle help` if you're stuck! <3
myMacintosh:~ futurebird$ 

Neither one works, I think because even after restarting, and trying to factory reset over and over it’s still not in listening mode.


I’m in the same case as you and have not find any solution …


This helped I was able to get CLI to seem to acknowledge my core.

2112-2:~ futurebird$ particle flash --usb cc3000
Found DFU device 1d50:607f
Apparently I didn't find a DFU device? util said  dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Found DFU: [1d50:607f] ver=0200, devnum=3, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg", serial="8D6C05795754"
Found DFU: [1d50:607f] ver=0200, devnum=3, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg", serial="8D6C05795754"

checking file  /usr/local/lib/node_modules/particle-cli/binaries/cc3000-patch-programmer.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/cc3000-patch-programmer.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 1d50:607f
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08005000, size = 25068
Download	[=========================] 100%        25068 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state
2112-2:~ futurebird$ 

But now it’s flashing magenta.

My core is still unable to connect.

The cc3000 binary flashes magenta while updating the cc3000 firmware, then goews back into DFU mode. Try the following:

  1. get your core into DFU mode (flashing yellow)
  2. run $ particle flash --usb cc3000
  3. wait for the core to finish the update (wait for it to stop flashing magenta, and return to dfu mode on its own)
  4. run $ particle flash --usb tinker

You should have a “factory reset” core, you can then re-upload wifi creds via telnet as you did before

Thanks. I tried this again… it’s been about an hour. How long should I wait?

Only a minute or so, I guess you have another problem on your hands.

@futurebird, what happens when you factory reset the core?

When I factory reset it flashed yellow, then white very fast. Then it goes to breathing cyan/ or white. It never goes blue. I can’t detect it over wifi with my phone or over serial OR wifi using CLI.

I’m confused now.

As is a core or a photon The title says core and the CLI seems to be handling a photon

It’s a core. I also have the old spark app… but I thought we had to upgrade.

There’s nothing wrong with upgrading the CLI. For the core, you will need to use the old Spark mobile app for it to work.

Anyways, can you take a video of the factory reset process?

I would also do the following:

  • Place in DFU mode
  • particle flash --factory tinker
  • particle flash --usb cc3000
  • particle flash --usb tinker

When I do this the first step works, but the usb cc3000 command causes my core to hang on the magenta flashing light.

Here is a video of the factory reset process:
(EDITED: to make it more clear what the video is for.)

@futurebird, you are holding the mode key for too long and putting the Core into factory reset. For the particle flash commands to work, you need to let go the mode key when the LED is yellow (before it turns white). Then try particle flash commands. :smile:

1 Like