Can't Claim Device, Rapidly Flashing Cyan with Red Bursts

Hi Everyone,

I have a particle photon. I played around with it using Zerynth, now I wanted to revert it back to Particle software. I placed the device into DFU mode, followed the instructions in https://docs.particle.io/support/troubleshooting/firmware-upgrades/photon/ and I was using part1 and part2 0.6.4 release binaries for photon device. The flashing finishes successfully as show in command line. However the MCU is not restarting and not running the Particle software. Am I missing something? Any help is appreciated.

Then what is it doing?

It just continues flashing yellow. I guess still in DFU mode. I tried power cycling and still blinking yellow

Could you try particle update and then particle flash --usb tinker, both in DFU mode?

1 Like

Hi @Moors7,
Thanks for the help, yes “particle update” did the trick and managed to download the Particle firmware. However, I’m faced with another problem, I tried connecting it to the web, steps were working fine, but at the last step, there was an error “Setup process failed at claiming your Particle device.” My photon is rapidly blinking CYAN color. Any ideas? Really appreciate your help

Cyan only or are there any other colors in there (orange)?
You could try giving particle doctor a shot, and running through those steps. (Make sure your CLI is updated to the latest version).

I gave particle device doctor a shot. During the process, it asked me if I want to remove the keys (that part I skipped deleting the keys because there was a warning that it might prevent me from connecting to the cloud). After running the doctor, it is still flashing cyan with some red burst. I’m searching through the forums, cant seem to find the definitive solutions.

Give the keys part of the doctor a shot after all, that might just be the issue :wink:

Not sure if this is required, but maybe also try reapplying the bootloader (available where you got the system binaries from)
In Listening Mode

particle flash --serial bootloader.bin

If particle doctor can’t cure it, you may be able to do it “manually”

particle keys server
particle keys doctor <youDeviceID>
1 Like

I actually tried following the suggestion here https://docs.particle.io/support/troubleshooting/common-issues/photon/.

PUBLIC KEY RESET

Sometimes, a firmware upgrade will not be enough to solve your Photon’s problem. If your are still having an issue, and particularly if your Photon is blinking cyan and sometimes orange/red without connecting, It’s time to try resetting the public key.
If you haven’t ever claimed the device before: You will need dfu-util. Install it, then download the this file. Use the command line to navigate to that file. Run the following command: dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der This should reset your public key.
If you claimed the device previously: You need the CLI. Once it is installed, run: particle keys server cloud_public.der particle keys new photon particle keys load photon.der particle keys send photon.pub.pem This should reset your public key.

However I still have the same problem, process failed at claiming the device

Yo Mate @ScruffR , your solution did the trick, I’m now breathing CYAN. Thanks a Lot. Thank you @Moors7 as well for your help.

1 Like