Cannot claim Photon - SOLVED

Hello. I am having some difficulty in getting my Photon setup/registered. Here is what I have done so far:
• Plugged in Photon to USB Power Supply.
• Blue Light on Photon was flashing
• Checked for WIFI signal beginning with PHOTON-XXXX (Nothing)
• Installed Windows Driver
• Installed node-js
• Ran npm update –g particle-cli
• Particle identify returns: Your device id is 2b0047…………. , particle --version 1.6.1
• Ran particle setup – Entered Credentials, Detected Photon via USB
• Received error, Potentially unhandled rejection [2] Serial Problems - No mac address found
• Reset Device
• Ran particle serial wifi
• Setup Wifi connection, light turns solid blue - Never connects
• Setup Putty Connection
• I – Returns Device ID
• W – Setup wifi  Solid light again

I have tried this with systems at my home as well as my office. No Luck.

Any suggestions on what else to try.

Thank You in advance.

Brian Barnholtz

If you’ve got DFU-UTIL installed, and you’re willing to give it a shot, you could try upgrading the system firmware.
Instructions, and files can be found here. You probably want to use the latest 0.4.4rc2 files. The commands can be found over at the 0.4.3rc2 release, where you’ll have to correct the versions accordingly.
If you haven’t got DFU-UTIL installed, but want to, here is a great guide to do so. Alternatively, here is a toolchain installer that will get you pretty much all software you could need for developing with Particle. CLI, Particle Dev, DFU-UTIL, Netbeans included.

Let me/us know if you need any further help/guidance.

Thank you for the information. I downloaded the latest firmware and used the DFU-Util to install. Still did not connect. I then did:
particle keys new
dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der
then hit reset and i am now connected and the photon is claimed.

Thank You Again for your help!


1 Like

How did you know to do this? Where did you find the clues that led you to this action? Finally, how did you know to use dfu-util for this? I haven’t found the documentation for dfu-util on the particle site; I’m probably missing it.

Do you think this procedure would help with my issue (described here: 1)


Doctek – Most of the help came from Jordy Moors. His response to my question, lead me to start with flashing the device. His email included links to the software needed. From the first link I was able to grab the Photon System – Parts 1 and 2, in addition to the installation steps. The second link directed me to the Zadig program which has the DFU Driver. His third link contained a link to the toolchain which allowed me to install the developer tools including the dfu-util. The information about regenerating keys came from another post in this forum.


Could that be this one?


Anybody can help me with this problem?
I have the same trouble as Brian.
I tried his fix:
particle keys new
dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der

… and I didn’t get any error messages but then my photon still didn’t connect to the network.
I also tried “particle serial wifi” and I set it all without any error messages. I then reset the device and it came back up blinking green but still not connecting to the network.

Thank you

This thread is that old, you better stick with your original one