Breathing Cyan but device doesn't show up/react [SOLVED]

Hello.

After having lost more than two hours and installed more than four different applications, I feel really deceived with the Spark Core product.

I am a senior developer, with experiencie in software and hardware develpoment, and Ihave developed succesfully many projects using arduino and my own designed boards. Time ago I bought a Spark Core because I loved the possibility of having Wifi on my project. My first tests were aborted as I disliked the idea of using an online tool to work with it, so time passed…

Today I was somehow urged to use the board, so I have spent all of my morning fighting against the horrible environment and set up procedure. After several attempts and restoring the factory defaults -the yellow flashing led is now a close friend of mine- I am stuck at the solid purple led. It seems than my firmware is too old to be updated online. Ok, I have installed DFU, Zadig, node, and when going for spark-cli -i think this morning I installed particle or something similar- some error about Github missing aborted the installation.

That is enough for me. I think the developer team is too focused on their “nice and original” developments that has forgotten about we users that only wanto to be productive with the hardware we bought. Additionaly I think that having the hardware I paid for currently unusable due to the willings of the company is barely legal.

I am so sorry my experience with Particle -AKA spark- ends here.

Regards

Hi @mermaja,

I’m sorry to hear that you’ve been having a difficult time getting started! You’ve come to the right place, the community is an awesome environment to seek out help. Do you want help troubleshooting the issues you’re running into? Have you emailed support or chatted with anyone?

Also, we try to make things easy to use and solve common problems, but giving up after 2 hours seems really quick! Any chance we can help?

Thanks,
David

Just as a quick followup here, auto-updating an original core should still be working, we haven’t changed that process at all over the last year. I’m guessing that maybe your WiFi network is really busy, or you have a high latency connection? Can you post the results of the DFU commands you’ve run, or anything? Or can you send me your device id or something, and I’ll check the logs?

edit: I also double-checked with our CLI team, and they’ve indicated to me that they fixed the ‘git dependency’ in the CLI over a week ago.

Thanks,
David

I’m sorry to hear your experience thus far hasn’t been as pleasant as it could/should have been. However, if you’re willing to give it another shot, I’m almost certain we can get you up and running. Some of these problems have shown up in the past, and we’ve almost always have been able to work it out.
Some questions/remarks if you’re willing to give it another try:

What environment are you talking about exactly? We’ve got the online Web IDE, the offline Particle IDE, the Particle-CLI, and potentially completely offline Local builds with your own Make process. Each of these requires a different approach, and each has its pros and cons.

That’s the first time I’ve ever heard about that. Seeing as I’ve been around for a while, the problem most likely lies elsewhere. Luckily, this can most probably be fixed :smile:

First of all, what operating system are you on? Some may require additional steps. Have you looked through the docs on how to set up the command line (particle-cli)? One of our awesome Elites, @kennethlimcp, made a neat tutorial on how to setup the CLI in Windows. There has been some debugging going on in this topic, including the GIT issue. IT really shouldn’t be too hard to fix.

Personally, I think they are very focussed on making the whole experience of creating a product as pleasant as possible. Please keep in mind they are still a start-up, growing, and learning a lot. They’ve already created some great products, but most importantly, they are committed. They will go out of their way to help you out if you’ve got issues/problems, and will do everything within their power to help you out. You won’t find a lot of companies who will react to forum posts within minutes (you beat me @Dave ;)).
The combination of different set-ups one can have is almost impossible to account for. Different operating systems, programs, experience, etc. make it incredibly hard to make one solid solution. That’s why I’m so glad we’ve got an amazing community, willing to help you iron out the kinks, and get you up and running.

It doesn’t have to end here. Consider it a rough start before an amazing journey :wink: Like I’ve said before, if you’re willing to give it another shot, I’m positive we should be able to help you out. The combined force of Particle, the Elites, and the rest of the community is one to be reckoned with :stuck_out_tongue_winking_eye: Please do no give up yet, you don’t know what you’re missing out on :smile:

5 Likes

First of all, I want to apologize for the rudeness of my first message, but it is sure that I have spent a great deal of my time in solving additional problems instead on focusing on my real needs.

As for now, I have been unable of having my Spark Core registered on the web so I am not able of trying the basic examples. I would like to do that to test how confortable the different environments are before starting serious developments.

The attempts I have done so far include:

  • Use the App both on Android and IOs, to the same result. Either breathing cyan with no device response/registering or solid magenta with the same lack of response
  • Use two different wifi networks, one at my university desk -very fast link to the Internet, simple WEP protection on the AP side- and the other at home -WPA2 with a reasonably good connection speed given spanish standards.
  • Use the particle setup tool that did not work at all this morning at the university, and that almost worked this evening at home, but previously I had flashed twice the firmware with the newest version I have found on your page. But at the end, the particle cli gave un saying too many attempts.
  • I have tested the DFU, result as follows

c:\Users\G\Downloads>dfu-util-static -l
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Found DFU: [1d50:607f] ver=0200, devnum=15, cfg=1, intf=0, alt=1, name="@SPI Fla
sh : SST25x/0x00000000/51204Kg", serial=“8D7C42794854"
Found DFU: [1d50:607f] ver=0200, devnum=15, cfg=1, intf=0, alt=0, name=”@Interna
l Flash /0x08000000/20
001Ka,108*001Kg", serial=“8D7C42794854”

The operating system I use is Windows 8.1

Thank you very much for your help

To add more information, I copy the result of my last attempt with particle setup

Serial said: Awesome. Now we’ll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit https://www.spark.io/support to debug.

Spark <3 you!

Done! Your device should now restart.
? Press ENTER when your core is breathing CYAN:
. Claiming the core to your account? Press ENTER when your core is breathing CYA
? Press ENTER when your core is breathing CYAN:
@ Claiming the core to your account? Press ENTER when your core is breathing CYA
? Press ENTER when your core is breathing CYAN:
. Claiming the core to your account? Press ENTER when your core is breathing CYA
? Press ENTER when your core is breathing CYAN:
! Something went wrong
! Out of tries [object Object]

C:\Windows\system32>

Let’s go with this one first. So it does seem that your Core is able to connect, but has problems at the claiming process. Could you try running particle identify/spark identify (depending on which one you’ve intalled), when in blinking blue mode. Then copy that ID, and go to the online IDE. In there, navigate to the Devices tab, and click “add new device”, and try pasting that ID in there.
Let me know how that works out :smile:


The Spark Core app is rather temperamental when it comes to connecting Cores. Sometimes it just doesn’t work, for unknown reasons, although likely related to the strange way it transfers credentials. The Photon is much more stable in this area.

3 Likes

@Moors7, @mermaja may not have Particle CLI installed and may instead have Spark CLI.

2 Likes

Thank you very much, Moors7, your solution worked.

But worked as to show me that the problem was generated by myself, so I apologize again. So I explain the whole affair to avoid the Particle Team to look for errors where there aren’t any.

The issue is that I had a previous account where I had the Spark Core assigned, so probably all the processes failed because the item was already owned. I must say that I have not been aware of creating a new account, so I thought, when I had logged in, that I was using the original one.

So at the end, thank you very much for your help and sorry again for my first message, that I previously recognized to have been too rude. I was too angry when I wrote it :frowning:

Regards

4 Likes

Glad to hear you’ve got it working! See, we’re not so bad after all :wink:
Thanks for explaining were the issue was, it might also help people facing the same difficulties in the future.
Happy to have been able to help out, that’s what makes this community so awesome: people helping each other :smile: That’s probably the biggest recommendation I can make for the future; If you get stuck somewhere, and you can’t for the life of you figure it out, come to the forums. There’s most likely someone who has faced the same issues before, and is able to help you out. And if not, we’ll at least be able to point to in the right direction.

Well, guess it’s playtime now, enjoy, and let us know if you need any more help :blush:!

4 Likes