Boron using wrong carrier

For a while now, I have been using a Boron for the development of a project. But from two days till now, the Boron has failed to connect to the network. I read the forums and I found I should factory reset the device then reclaim it to my fold. During the reclaim process, I saw that the carrier has been set to kore_vodafone instead of Safaricom as it’s meant to be in My country.

What happened here? Please help

That’s not what that message means. It will say that for all Boron 2G/3G, E313, B523, and T523 devices. It’s the type of MFF2 SMD SIM, not your specific mobile carrier.

It looks like your device is fully unclaimed and the SIM released. If you’re still having trouble activating it after a few hours you should submit a support ticket.

Ok. It has been a couple of hours since I posted. Just tried it again. Still doesn’t connect. Raising a ticket

I switched to a local sim card and setup the device using that. That works fine. I can go online now. But, I’d much prefer the onboard simcard for my project.