Boron not connecting to cloud after reactivating SIM

I have a unit down in another state that had reached its data limit, so I had to unpause the SIM and set a higher data cap.

It has been about an hour since I have reactivated the SIM, and my device is still unreachable by the device cloud.

Is there any additional step I am missing to get the device to reconnect after its SIM was reactivated?

Obviously, with the unit being in another state, I have very limited information about what the status LED is doing and any kind of physical interaction with the device is off limits at the moment, due to the nature of the installation location.

I’m sure that my code is working, as I had flashed it several times yesterday and nothing has changed, besides a more consistent cellular connection than I was experiencing a couple days ago.

Any help would be appreciated, as we would rather not have to send someone to another state to unplug the unit and plug it back in.

P.S.

My SIM says that it is active and in the email I received from Particle confirming that the SIM had been reactivated and that the data limit had been reset, it had said that data usage can take them up to 24 hours to figure. Is there any possibility that I have actually used more data than what it is telling me? It says that the device has used 6 MB this month, but is it possible it has used over 50 MB (my current data cap) and its just not displaying in the console?

I’ve had trouble restarting after a paused SIM also, but on Electron. I’ve been trying to figure out why and am planning to do some more testing when time permits.

My firmware would wake to take readings, send a publish, and sleep. I used

if (!waitFor(Particle.connected, 180000)) {
System.sleep(SLEEP_MODE_DEEP, 1200, SLEEP_NETWORK_STANDBY);
}

to save the battery from depleting in the event of a cellular outage.

It turns out that this was too short, because when I unpaused the SIM, it took roughly 5 minutes to reconnect successfully. I had to put it in safe mode so that it wouldn’t time out and go to sleep. This is with fair to good indicated signal strength, and my normal wake would reliably connect in roughly 10 seconds with SLEEP_NETWORK_STANDBY, so I don’t feel this is due to low signal strength.

I tried this at home with another electron, after a SIM pause due to going over it’s data limit, it again took between 5 and 6 minutes to reconnect, also with Good indicated cellular signal.

My current firmware tries once a day with a particle connect timeout of 6 minutes, otherwise using 2 minutes.

The data usage can be delayed but with my Boron LTE unit is 1 day behind.

There is or was a issue where the actual data usage was being doubled by accident on the backend causing you to set your data limit to be above double your current data usage to get it to reactivate the sim.

Once I set my data cap to 50MB it reconnected in 10 mins.

For reason(s) still being determined, there can be a somewhat unpredictable delay in activating/deactivating Boron SIMs (and E Series LTE too). In addition, data usage metrics are also delayed. We are working with the cellular provider to improve this.

I re-activated a Boron LTE a few days ago and it took somewhere around an hour to get happy. I have heard of it taking a day, which is clearly not cool at all.

I’m not sure what the deal is about @jimbol’s Electron though.

@ParticleD,
I just started a new topic related to my SIM unpause experiences, I learned why my Electron would not reconnect:

1 Like

Just an addition to this thread to relay more experiences with this issue. I went past my 5mb data limit Sunday (4/7) at 6 am per the email. I raised the data limit to 10mb at 1pm on Sunday and reactivated the sim (confirmed with emails from particle). It’s now 10 am on Monday (4/8), and I still haven’t been able to reach the device. Data usage rolled over for the month today so everything is back at 0mb. The device has continuous power, so no deep sleep or anything else in the coding. Fortunately, we will be able to power cycle the device sometime today (somewhat remote but not out of state). I’ll write another message here if it still doesn’t connect after 24+ hours.