Boron is completely dead

Something is totally wrong with my Boron 2g/3g.
I suppose something wrong with my bootloader. I tried to upload a bootloader different ways (using JTAG), for instance using openocd and script. The only way the Boron boots up (in DFU mode) is if I use for softdevice uploading and then a bootloader, but without address specification, namely like that: --flash-bootloader-bin /path/to/boron-bootloader@1.4.4.bin
If I specify the address according to the manual (0xf4000) - Boron does not boot.
I can successfully upload system-part1 and a Tinker, but Boron never boots in a normal way and can be accessed only in DFU mode (probably because of bootloader issue).
If somebody can give me the right way to fix it, I would be appreciated.

Have you tried particle flash serial boron-bootloader@1.4.4.bin and also what about softdevice?

I can’t change the mode to listening, so I didn’t try to flash through serial. And I flashed boron-softdevice@1.4.4.bin before bootloader

Sorry to say but this issue sounds somewhat self-inflicted?

Have you tried Particle Doctor? I guess that needs listening (flashing dark blue) mode?

Lastly, perhaps logging a support ticket is the next step.

@vitaly_pochtar, you may want to take a look at these posts:

Most likely the bootloader address needs to be reset. Using the nrf52-particle.cfg configuration file use this OpenOCD command:

bld_addr 0xf4000

The symptoms you are seeing would match having a bootloader address of 0. That would allow boot to start when you flash the bootloader to 0, but the device would never boot correctly because the SoftDevice needs to be at 0 and the bootloader at f4000 to boot Device OS.

1 Like

Thanks for the advice!
Eventually, after hundreds of tries, I have found the right sequence.
The main issue (I suppose) was in a softdevice file. Instead of using boron-softdevice@1.4.4.bin I uploaded s140_nrf52_6.1.1_softdevice.hex and then, uploading all other files (bootloader, system, tinker) I finally launched tinker successfully.

1 Like

Hi @vitaly_pochtar … i’m having the same issue. In my particular case, i have a bricked argon. Thanks to your advice, with flashing the bootloader with no 0xf400 address, at least i can put it in DFU mode. but, from there, i try to upload s140_nrf_6.0.0_softdevice,hez file with openocd, and it bricks again. Could you please tell me a more detailed description with the steps and tools you used, along with a llink to the s140_nrf52_6.1.1_softdevice.hex file? Please, help. Thanks

@fbt - the Argon may be a bit different here.

For the record, it’s always worth using the conventional upgrade path of:

(particle flash --usb tinker
and then)
particle update
and then
particle flash --usb tinker

before digging deeper and flashing to specific memory locations.

It might be worth opening a support ticket ( so that we can dig a little deeper.