Boron Flashes Red - Unable to recover

Out of about 100 devices in the field I got about 10 that over time started flashing red 10 times. I’m certain it’s not my code. The ones that were affected are Boron 402s running version 2.3.0 or lower. I’m unable to recover them even when using the debugger and I’ve open a support ticket with no luck. They were powered by the vusb pin and had a battery connected as well. Any ideas what can be causing such a high failure rate? Any ideas on how can I narrow down the root cause of this? I’m willing to provide a bad Boron to anyone that can tell me what is causing this.

When does the SOS+10 occur? Immediately at boot, after blinking green, etc.?

Can you get into DFU mode?

What steps have you done so far?

  • Device Restore (USB/DFU)
  • Device Restore (JTAG)
  • Erase the external flash (DFU)

8 out of 10 start blinking immediately after power them up and I’m unable to put them into DFU mode. I have tried all the options that support sent me.
The remaining 2 start flashing magenta but after a few blinks go into SOS+10. I can put them into DFU mode and tried the restore options, particle doctor, etc but no luck.

As far as what I have tried: Device Restore (USB/DFU), Device Restore (JTAG) and I believe I have done the Erase the external flash (DFU) but can you share what the steps are for that just so I can verify.

Any insight greatly appreciated. I’m happy to ship a few of the chips to get down to the bottom of this.

Also here is the full details on how the Boron is powered Schematic design feedback

No one else ran into this issue? If that is the case what can I be doing wrong?

@Colleen support told me to ping you on this. Any thoughts?

Have you tried the device doctor ? What about a factory reset?

Are the boards physically damaged in any way?

Tried everything and no physical damage.