Boron Connection Issue

Hi!
I’ve been having quit a few go arounds with boron devices lately. I’ve got a very simple code that I’d like to figure out how to keep loop running if the cell connection ever goes down. After reading the docs and trying to learn how SYSTEM_THREAD(ENABLED); works, I was able to get Argon devices working correctly. But trying this approach hasn’t worked for me yet on these borons. I’m wondering if the connection to the cloud is taking longer and something in my setup is causing issues. I’m getting the 4hz green flash for about 8 sec. than everything goes dead for a second than I get a white flash and than the green flashes again. If someone can point me to what this means and where its documented, I’d sure appreciate it.
So I’ve taken out the system thread and am trying to just get some basic code running on boron. I can get it flashed and running for awhile but as soon as I try to send out something over cellular things crash and I get the green flashes and than the single white for awhile. It will eventually reconnect… stays connected until cellular data sent. So… I thought something down this line was my problem: Boron Resetting (flashing green with intermittent reset) but adding in those resistors doesn’t seem to make any difference here.

It’s hard to say without seeing your code.
However, cell connections tend to take considerably longer to be established and the communication with the cell NCP is much more elaborate than for WiFi. Hence the impact will be greater.

One thing you should consider in any case is to actively disconnect from the service when your code can assume that the auto-reconnect won’t succeed for longer periods (e.g. no coverage area) and only try a “manual” reconnect at longer intervals where you can have the rest of your code react appropriately as it “knows” about what’s going on. With auto-reconnect you code has no real overview of what is happening when.

However, the RGB LED pattern you describe would rather point to a under-power behaviour.
Have you got the LiPo connected?
Is it a LTE or a 2G/3G Boron?
What other things have you connected?
How does your HW setup look at all?

1 Like

Just commenting here to follow this thread… I also have been intermittently getting device resets similar to what you are describing. The device will continually reset itself right as it is connected to the particle cloud. I know it’s resetting/pseudo resetting as it re-calls the Setup() function… here is a lengthy thread talking through what I was trying to do. Went down a few rabbit holes and still don’t think I know what’s going on. Boron - Seemingly random device reset - How to best capture the reason - #19 by jgskarda

This sounds unusual however, for me, it seemed to never happened when plugged into USB when monitoring Serial log and only happened when connected to LiPo battery. Secondly, it seems to happen for the first 2-24 hours of a brand new Particle Boron, almost as if there was a “burn in period”, maybe there is some sort of handshake that must happen with the cell tower before it can establish a connection without resetting. Not really sure. This also did not happen on every single Boron I commissioned but rather maybe 2 out of 10. After a day or two though, then it seems it never happens again. I hope to fully document/record/capture all the information as I commission the next set of Boron’s in hopes of getting to the bottom of it. Should be next week sometime when the next batch arrives.

Please keep commenting!
But if you wanted to “silently” follow a thread you can alternatively “watch” the thread:

image

Even then, you can combine both, so if people do not reply directly to your comment or mention you you still get notifications about activity in it.
Best
Gustavo.

1 Like