Boron can't connect to cloud

boron-3g
Tags: #<Tag:0x00007f1ca149c888>

#42

@peekay123 I’ve got the 2G/3G version. I was aware LTE only works in the US at the moment so I went with that one. I almost want to come down to Ottawa to test it there… I’m in London, which is not too small of a city and we’ve definitely got a good Tellus coverage. I’ve already tried to connect at three different locations in the city with no luck. Now that you said you have no issues connecting in Canada I wonder if there’s something wrong with my Boron after all…


#43

Hi @toropov any feedback from your side ? I had the same problem twice … recreat a ticket (74232) but no news about particle.

Hi stopped my boron some days and at the restart …is blinking green. Last time @rickkas7 did a manual operation who forced me to reinitialise my SIM …

It so upsetting …could not work on my platform … :weary:


#44

It works!
So I’ve been in contact with the support team for quite a while and yesterday I was told to flash my Boron with the latest firmware as well as the new debugging tool. I did all that and it didn’t work at first. Then I decided to scan for providers while the antenna was detached just to verify that it wasn’t the issue. It didn’t connect at first as I expected and so I collected logs and went on to sending the email response. Then the Boron started to breathe cyan! With the antenna detached! I opened the serial port and saw some logs that said: “connected to cloud”. I then quickly plugged the antenna back in, it kind of rebooted I think and then connected to cloud once again! I then put it in listening mode, registered with the app and everything works now.

So here’s all that I did what got this thing to work for me (mostly copied from support email):

  1. Install/update the CLI tool
  2. Download the 0.9.0 system, Tinker, and bootloader .bin files for your device from the repository
  3. Put it in DFU mode
  4. particle flash --usb system-part1-0.9.0-boron.bin
    particle flash --usb tinker-0.9.0-boron.bin
  5. Now, put the device into listening mode and
    particle flash --serial bootloader-0.9.0-boron.bin
  6. Follow instructions here to flash the debug tool and it will run the tests.
  7. Now, this is what I did after what the support team told me to do: Scan for providers (read the link above). Detach antenna and scan again. Wait till it connects (breathing cyan) and snap the antenna back on. Everything works then put in listening mode and register with the app.

This is probably just a coincidence that it happened to connect with the antenna detached and it’s probably due to the update, but I dunno, the Boron is sitting exactly where it was sitting all those countless times I tried to make it work. I never worked with the antenna attached and now somehow it works without the antenna and even with the antenna back in place ¯\_(ツ)_/¯


#45

i will try the news firmware and your advise ! thanks @toropov