Boron Breathing Cyan but unable to claim it


#1

Hello!

I have a Boron with a 3rd party SIM, it is currently breathing Cyan (which I understand it means its already connected to the network ). Nevertheless, I’m unable to claim it, I tried through the web editor and the CLI, It just says the device is not connected. I checked the device ID using the CL. As a newbie, I’m out of ideas…


#2

You’ve seen this new section of the documentation, correct? https://docs.particle.io/support/particle-devices-faq/electron-3rdparty-sims/#setting-up-a-3rd-party-sim-card-boron


#3

Yes sir, I’m exactly following that tutorial . I’m stuck in the “claiming device” part, I cant do it despite my Boron is breathing cyan. It does not say anything about what to try if you cant claim the device.


#4

This is what I do:

  1. I put the boron in blinking dark blue mode, then in the CLI I type “particle identify” and I get the device Id.
  2. Then, I reset the boron and starts normally breathing cyan. Then, I type "particle device add + the device Id I got in step 1. I get: “Failed to claim device: Device is not connected”

What I’m doing wrong?


#5

Well, your 3rd party SIM probably has a short keepalive time and you will need to flash a user firmware that sets it to a much lower value for it to remain “online” for claiming.


#6

I solved it, it was a very stupid mistake in deed. It turns out it wasnt breathing Cyan, it was breathing white, which means a total different history. I updated the firmware and it works! Thank you!


#7