Boron 404X not able to setup

I am trying to setup up a new Boron 404X device right out of the box. I've plugged it into a USB and windows (W10) does not recognized the device. I tried this on another computer of mine (W11) and same story. I have installed the Particle CLI for windows on both computers.

From what I have read, I think I need to activate the device, run it through the setup.particle.io webpage to enable the SIM so I can program this. But I am unable to connect to the device. So far, I have not seen anyone else with this same issue. Most of the posts I have found mention a mobile app, as does the start up video from particle.io, but that is no longer available.

Does anyone know what I may be doing wrong? Or what my next steps should be? Do I need a different set of drivers? I'm not sure where to get those if so. I have tried several different USB cables as well.

Thanks for any advice or input in advance!

I bought another cable and that we the problem. My understanding was that USB cables with the trident image on them were all certified to the USB standard. That is apparently incorrect, as 3 cables I have here do not work for data. I bought a new one that guaranteed fast charging, so all internal wires are connected and this device showed right up in Windows and gave me a port to communicate.